Can-Am Maverick Forum banner

21 - 40 of 580 Posts

·
Registered
Joined
·
190 Posts
Mine was making a sound similar to that. Mine was a loose nut on the front torsion bar connected to the sway bar.
I will check that out. Thanks.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
320 Posts
Ya what he called it.. lol. Thanks for the help on that, I'm fairly new. Anyways, after a visual inspection I found nothing, until I rocked it side to side pretty hard. My sound was coming from the shock just below the crossover rings. While rocking it is when I noticed that nut had came loose. I tightened it and clanking went away.
 

·
Registered
Joined
·
40 Posts
I too had a couple power steering moments that happened during tight maneuvering (trees) nothing was noted on computer though.
 

·
Registered
Joined
·
349 Posts
I too had a couple power steering moments that happened during tight maneuvering (trees) nothing was noted on computer though.
Nothing was noted on my computer either.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
3 Posts
Yes, we need a thread.

New X3 with 260 miles, love it so far. Primary clutch stays slightly engaged at idle (1400- 1550) turning the secondary and loading the transmission. This makes it hard to shift thru P,N,R,L,or Drive. The primary sheaves are dragging on the sides of the belt. Anybody else having this problem? FYI the owners manual misprint page 87 oil + filter change 1.8L or 1.9qts. and page 113 oil + filter 3.5L or 3.7qts.
 

·
Registered
Joined
·
320 Posts
Yes me too. Mine is at the dealer with a check engine light issue. I brought up the shifting issue to the mechanic. He told me that can am wants him to reprogram the ecu so that it idles at 1200, i hope it works. I'll pick it up later this week
 

·
Registered
Joined
·
212 Posts
Tough time shifting for me as well. Small weep hole on the passenger side of the motor near the "rotax" cover is making a small mess. I'll post a pic tonight. Front diff is no good as expected for serious rock crawling. But I followed some rzr up nasty stuff in 2wd more or less. Also had that snapping sound, tightened the driver side front sway bar mount and it fixed it. I have noticed a bunch of side to side play in the sway bars. You can grab em and move them an inch easily. Doesn't seem right. Might put clamps on them soon unless someone has an explanation of why it's ok.
 

·
Registered
Joined
·
24 Posts
I broke a wheel at 50mph. Hit a baseball size rock at just the right angle and it broke my right rear rim. Is this normal? I hit some rocks going through turns the same size that day and no issues. Just wondering if need to drive/drift better or are the stock rims supposed to handle something like this?
 

·
Registered
Joined
·
5,743 Posts
Yes, we need a thread.

New X3 with 260 miles, love it so far. Primary clutch stays slightly engaged at idle (1400- 1550) turning the secondary and loading the transmission. This makes it hard to shift thru P,N,R,L,or Drive. The primary sheaves are dragging on the sides of the belt. Anybody else having this problem? FYI the owners manual misprint page 87 oil + filter change 1.8L or 1.9qts. and page 113 oil + filter 3.5L or 3.7qts.
The primary clutch was Torqued down to tight and the bearing was damaged. Need to talk to guys at Ridenow Peoria as they had to fix one of my friends cars.
 

·
Registered
Joined
·
24 Posts
I've also had check engine light come on 2 times. Shut it down and restarted 2 'in later. Still on. So I drive slow back to truck and after 1 mile it turns off. Talked to dealer - but they are clueless. It's so new they have no idea what the hell to do.
 

·
Registered
Joined
·
212 Posts
Yes, we need a thread.



The primary clutch was Torqued down to tight and the bearing was damaged. Need to talk to guys at Ridenow Peoria as they had to fix one of my friends cars.
What was the sign of this problem? I'm hearing more than intake sounds through the intake duct. I swear I hear bearings or rollers chirping, it's hard to describe but the clutch sound (what I'm calling it) is much louder than the intake whoosh. It's deafening. Maybe like a kazoo but higher pitch?
 

·
Registered
Joined
·
5,743 Posts
What was the sign of this problem? I'm hearing more than intake sounds through the intake duct. I swear I hear bearings or rollers chirping, it's hard to describe but the clutch sound (what I'm calling it) is much louder than the intake whoosh. It's deafening. Maybe like a kazoo but higher pitch?
I'm sure it's the one way bearing in the primary clutch. If it was over torqued it will make it stay engaged and creeps in gear and damn hard to shift.

Sent from my SM-N930T using Tapatalk
 

·
Registered
Joined
·
5,743 Posts
The primary clutch has a 2 way bearing

Sent from my SM-N900V using Tapatalk
There ya go. They damaged it by over torque

Sent from my SM-N930T using Tapatalk
 
  • Like
Reactions: Tight_trails.

·
Registered
Joined
·
1,130 Posts
Here is the video of the clicking. I wasn't doing anything too extreme.



Sent from my iPhone using Tapatalk
Yes, mine makes that noise too. Mostly when transitioning over things. When I drive in a straight line (fast or slow) even over whoops, it does not make the noise. Mine makes that noise less now that things are broken in more. Maybe it's the sway bar like someone said?
 
21 - 40 of 580 Posts
Top