Can-Am Maverick Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
227 Posts
Discussion Starter #1
I been trying to get my front axles in the diff on my ride and I can't get them to stay in.....I read about the 2 piece c-clip thing but for the life of me mine won't stay in.....as soon as I tighten the bolt for the shaft on the hub side the axle jus pops right out of the diff...someone please enlighten me on this!! thanks
 

·
Registered
Joined
·
272 Posts
Check this video out it helped me when getting my passenger side axle in.

 

·
Registered
Joined
·
227 Posts
Discussion Starter #3
saw that.......hoping something aint wrong in my diff.....I even changed out the C-clips
 

·
Registered
Joined
·
272 Posts
I know if the inside set of splines aren't inline with the outside set on the passenger side it won't go in. When I carried my diff to Kelly (kellylmann) he told me when I got it back from him everything was inline and ready to put axles in. His brother told me not to baby it. I was worried I was gonna mess something up going easy with it. Getting pass the first set of splines was easy but then getting it to lock on the second took me a few tries. You should have maybe an 1/8" gap between dust cover and diff. If it's all the way in and locked you can grab in between cv boot and dust cover and pull on it and it shouldn't come out. If it does then it didn't lock in place.

Sorry if this wasn't helpful, I don't know what else it could be.

Nathan
 

·
Registered
Joined
·
227 Posts
Discussion Starter #5
I know if the inside set of splines aren't inline with the outside set on the passenger side it won't go in. When I carried my diff to Kelly (kellylmann) he told me when I got it back from him everything was inline and ready to put axles in. His brother told me not to baby it. I was worried I was gonna mess something up going easy with it. Getting pass the first set of splines was easy but then getting it to lock on the second took me a few tries. You should have maybe an 1/8" gap between dust cover and diff. If it's all the way in and locked you can grab in between cv boot and dust cover and pull on it and it shouldn't come out. If it does then it didn't lock in place.

Sorry if this wasn't helpful, I don't know what else it could be.

Nathan
sounds good..I will mess with it some more later..I think I was just getting frustrated so ill leave it alone till this weekend...thanks
 
1 - 6 of 6 Posts
Top