Can-Am Maverick Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter #1
So ever since I brought my maverick in for the first service it stalls out now. If I'm in the snow and hammer on it an just left of it will stall out or if I spin around on the ice and let off half way thru it just stalls out some times. It never did this before the service so why would it now?
 

·
Registered
Joined
·
4,536 Posts
ummm I would take it back to the dealer and tell them , its there problem !
 

·
Registered
Joined
·
252 Posts
Clean your air filter
 

·
Registered
Joined
·
4,536 Posts
air filter wouldn't cause it
 

·
Registered
Joined
·
528 Posts
Id also have them check the TPS (throttle Position Sensor) My Commander had those symptoms when TPS wasn't calibrated.
 
  • Like
Reactions: Mr.Chep

·
Registered
Joined
·
468 Posts
Fuel pump might be messin up (I stress the "might"). Had the same type of shit happen on my old Rincon 680. Thought it was all kinds of stuff but ended up being the fuel pump. Either way I'd take it back to the dealer.
 

·
Registered
Joined
·
121 Posts
Discussion Starter #10
I hate to even deal with them. My 200 dollar service when they sold it to me came to 350 when the time came and tried to charge me for doing the front diff when they didn't. I have to drive sixty miles one way to bring it to them and they haven't been very good so far.
 

·
Registered
Joined
·
4,536 Posts
sounds like a fuel problem , also there suppose to remove and clean your speed sensor to maybe they didn't clip it in tight or didn't clean it, lol
 

·
Registered
Joined
·
791 Posts
Call the dealer, ask them what all they worked on. They might be able to tell you what connections they had apart or what to check
 

·
Registered
Joined
·
121 Posts
Discussion Starter #15
I called them about an hour ago. They were supposed to call me back in a few minutes but haven't heard back
 

·
Registered
Joined
·
121 Posts
Discussion Starter #16
I called them again they told me to try and reset the ecu. Does anyone know if when I do that if it is supposed to say anything across the screen?
 

·
Registered
Joined
·
4,536 Posts
seach commander ecu reset
 

·
Registered
Joined
·
2,067 Posts
If they adjusted the valves to tight it can cause the motor to die when you chop the throttle. Had it happen on other machines, sure fire way to know when it's time to adjust the valves.
 
  • Like
Reactions: hooversxs

·
Registered
Joined
·
121 Posts
Discussion Starter #19
If they adjusted the valves to tight it can cause the motor to die when you chop the throttle. Had it happen on other machines, sure fire way to know when it's time to adjust the valves.
I'm thinking it has to be the valves. They said they adjusted them and that's really the only thing that they messed with that would cause it to do it. I took a video of it doing it with my phone but dont know how to post it from phone. It doesn't do it every time just here and there.
 

·
Registered
Joined
·
1 Posts
I'm thinking it has to be the valves. They said they adjusted them and that's really the only thing that they messed with that would cause it to do it. I took a video of it doing it with my phone but dont know how to post it from phone. It doesn't do it every time just here and there.
My Maverick is doing the same thing Did you ever find out what the problem was?
 
1 - 20 of 21 Posts
Top