Can-Am Maverick Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter #1
OK Guys, heres the deal, before I got the recall on the clutch fixed, while I was driving it, I heard a whining noise just before the clutch broke. I took it in got it fixed. Now, I Just went to Glamis this weekend, First trip since the recall was fixed. After a few hours of driving it, I herd the same whining noise again. I got worried and stopped driving it in the dunes, thinking the belt or clutch was going to break again, and stuck to the flats. It made that noise the rest of the day, even after pounding a few beers for a couple hours, it still made that same noise. Sunday morning I got in it to load it up and it wasn't making that sound anymore. I'm wondering if any of you guys have heard that same whining noise. Is it the nature of the beast, or is something going on. This really sucks, cant really dune in a vehicle you don't have confidence in. any and all feedback would be greatly appreciated. . . .Thanx
 

·
Registered
Joined
·
2,964 Posts
Never had that noise. When my belt blew, it just let go with a bang. But my clutches are aftermarket, and only had 3 rides on the stockers
 

·
Registered
Joined
·
35 Posts
I just got mine brand new two days ago and I can hear a whining coming from the breather tube that goes to the belt, don't know if that's the same.
 

·
Registered
Joined
·
6,621 Posts
So your stock clutch broke. What was it? Primary bolt? Any other damage?
 

·
Registered
Joined
·
7,381 Posts
So your stock clutch broke. What was it? Primary bolt? Any other damage?
I can hear a whining noise when the belt heats up but haven't ever blown a belt or damaged a clutch…..not so much now that I have aftermarket clutches but much more when I had the stock clutches….
 

·
Registered
Joined
·
175 Posts
Mine also makes a whining noise at slow steady speeds, it started after I had the clutch recall done. I am thinking it's just the belt or something but I've never figured it out yet.
 

·
Registered
Joined
·
4,536 Posts
OK Guys, heres the deal, before I got the recall on the clutch fixed, while I was driving it, I heard a whining noise just before the clutch broke. I took it in got it fixed. Now, I Just went to Glamis this weekend, First trip since the recall was fixed. After a few hours of driving it, I herd the same whining noise again. I got worried and stopped driving it in the dunes, thinking the belt or clutch was going to break again, and stuck to the flats. It made that noise the rest of the day, even after pounding a few beers for a couple hours, it still made that same noise. Sunday morning I got in it to load it up and it wasn't making that sound anymore. I'm wondering if any of you guys have heard that same whining noise. Is it the nature of the beast, or is something going on. This really sucks, cant really dune in a vehicle you don't have confidence in. any and all feedback would be greatly appreciated. . . .Thanx
ur prolly hearing the funny howling wine sound of the clutch , if ur worried and half ass handy remove the clutch side cover and re-TQ bolts to double check , after that anything else is just wasting time, so get out there and ride
 

·
Registered
Joined
·
874 Posts
ur prolly hearing the funny howling wine sound of the clutch , if ur worried and half ass handy remove the clutch side cover and re-TQ bolts to double check , after that anything else is just wasting time, so get out there and ride
So that funny howling noise is normal on all of them? I hear mine when in neutral and give it a light rev more than anything.
 

·
Registered
Joined
·
668 Posts
Never rode a canned ham that didn't whine. Put snorkels on and you will hear the whine for sure.
 

·
Registered
Joined
·
806 Posts
Your sheaves probably have residue on them. If your sheaves are dirty you will start to hear a whine after your clutches get hot. It is really bad with the gates belt.
 

·
Registered
Joined
·
4,536 Posts
So that funny howling noise is normal on all of them? I hear mine when in neutral and give it a light rev more than anything.
yes u can try n clean your sheaves with green scotch brite to remove oil residue if any
 

·
Registered
Joined
·
6 Posts
I recently went to Ocotillo for presidents weekend, mine did the same thing. I thought it was a belt or cutch but after the first couple days the noise stopped. This was just the start !! I just had the ten hour service completed and this was the first ride since. I was about six miles from camp when the engine went in to limp mode, with no engine indicator light. I got it back to camp and discovered the idiot who did the maintenance soaked the secondary filter in oil and stuck it back, this caused oil to get sucked in to the intake and gooped up the mas air slow sensor. The computer is throwing a PO131 code which is a 02 sensor...I couldn't get the thing to run right ruined the trip!! I'm taking it back to the dealership this week, ill ask about the whining noise and get back with you.
 
1 - 13 of 13 Posts
Top