Can-Am Maverick Forum banner
1621 - 1640 of 2054 Posts

·
Registered
Joined
·
881 Posts
Trying to wrap up my comms. In-car only at this time,,, may or may not do car to car at a later date.

Didn't want to hack up my dash to install the RR or PCI facia. It looks the best and is probably the easiest, but I just didn't want to cut up my car. AND,,, some angles I see pics of they look pretty good,,,, some they don't look so good. Took a stab at making my own mount.

Cut up some aluminum brackets after mocking it up with fiberboard...

268682



Threaded and bolted the base plate to the sides since things were pretty tight fit. I wasn't really sure if I would have to partially install it and put the last side together after it was going in. Turns out I could have welded it together,, but she's a REALLY tight fit.

268683



Test fit prior to paint... Thought about leaving it bare alum,,, but I don't like the way it looks, so I'm gonna throw some black hammer-tone on it. (hopefully make it fade into the background a little more.)

268684



This is why I built my own brackets in the first place. I wanted the unit tucked up right under the start button. My wife and I can both reach the PTT buttons really easily from here (if I go that route) and the controls are up away from the shift knob enough that I don't have to reach around the shifter to activate any controls. I went with the 362 due to the integrated PTT buttons. (not a fan of the wheel mounted buttons etc... lets hope mine works better than some I've read about since my purchase.)

It's a bit off center in the dry run, but it's literally just sitting in place in this pic,,, not bolted in yet. I hope to center it up better when I mount it permanently.


268685


Paint is drying now,,,, update with a couple of final pics when it's dry and fully installed.
 

·
Registered
Joined
·
215 Posts
I have a set of the LM rods on my rig. I noticed you had some, so I wanted to check how you had them set up for exactly the reason you stated - no instructions! Ha!
I bought a set of LMUTV rods while I was on the road, and installed them in the dark, at an RV park. LOL

Second guessed it, and sent them an e-mail with pics to verify I had them installed correctly. Couldn't find any instructions, or a pic of their new style. They did respond saying all was well.

268723
 

·
Premium Member
Joined
·
14,297 Posts
  • Like
Reactions: Vagabond

·
Registered
Joined
·
440 Posts
going to wash mine tonight most likely to get it cleaned before i get it dirty again this weekend. gotta start with it clean! heading to northern wi for a long weekend riding with my buddies so that should be fun.

havent done much with mine the last few weeks... ordered some q700 tires for the stock rims when i finish wearing off the big horns or decide that they are bald enough to want to change them. for 8 ply tires, the $110/$120 each wasnt too bad from Chaparral to burn them up on the roads.

steve
 

·
Registered
Joined
·
881 Posts
Wrapped up the comms... Completed final install on the Unit bracket, and installed the cables up to the helmet location. Decided against routing the cables to the harness since they are the retractable type,,, AND I pull my seats often. Didn't want to mess with it every time I pull my seats.

Tried routing them up to the cage, and attaching them with some Para-cord bungee so they will stay up near my helmet on their own, but if I turn my head way too far, lean forward, etc, the bungee should stretch enough so I don't "come to the end of my leash".

268839


268840


268841


268843
 

·
Registered
Joined
·
276 Posts
This past week I got dual 4-foot LED whips from 5150 (their 187 model) installed. Controlled by an app on your phone they're VERY cool and their warranty is insane...wreck at the dunes and they'll still send you new ones!

Also got Scott F's/XMX radius rod nut plate upgrade kit installed which is super solid must do mod for very short money...
 
1621 - 1640 of 2054 Posts
Top