Can-Am Maverick Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
i have owned my maverick for 1 month now. i have been getting a weird stuttering, not for the engine but from the drive terrain. It almost feels like the belt is wet. i know its not though. any one else have the same issues??
thanks
 

·
Registered
Joined
·
707 Posts
The belt is probably glazed. Pull the belt off and if the sides are shiny its glazed. It's from the clutch letting the belt slip and it getting hot. Once the sides are glazed its hard for the clutch to grip the belt. Does it happen when first taking off?
 

·
Registered
Joined
·
329 Posts
Friend had same problem. The belt is glazed. Most likely small spot on side. Sometimes hard to see. Does not have to be large.
 

·
Registered
Joined
·
2,067 Posts
Mines done that to a certain degree since I brought it home. I think it's just clutch engagement is sloppy under light throttle. I just give it a bit more throttle to get rolling and then it's ok. Mine has never like slow rolling. Only had 2 miles when I brought it home so I doubt the dealer did anything. I'm not worrying about it but if you do think it's glazed you can pull it and clean it. AReed posted recently a method to wash and scrub the glazing off as opposed to replacing the belt. Maybe try checking your top speed and see how it shifts at full rpm. If it is glazed I'm not sure you would see top speed around 76mph since it would likely slip some. Don't hold me to that though and if I'm wrong I'm sure someone will correct me. Makes sense though.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #5
Mines done that to a certain degree since I brought it home. I think it's just clutch engagement is sloppy under light throttle. I just give it a bit more throttle to get rolling and then it's ok. Mine has never like slow rolling. Only had 2 miles when I brought it home so I doubt the dealer did anything. I'm not worrying about it but if you do think it's glazed you can pull it and clean it. AReed posted recently a method to wash and scrub the glazing off as opposed to replacing the belt. Maybe try checking your top speed and see how it shifts at full rpm. If it is glazed I'm not sure you would see top speed around 76mph since it would likely slip some. Don't hold me to that though and if I'm wrong I'm sure someone will correct me. Makes sense though.
that sounds about right. its only when i am slow rolling but when i hammer on it goes. i do reach that speed as you where saying. i am planning on putting an air dam clutch in it soon. so i will check the belt for slick shinny spots also.

thanks for your guys input
 

·
Registered
Joined
·
32 Posts
Its glazing, mine did it. The area glazed is only 8cm long, and only on one side, but it was terrible at low speed and takeoff. I replaced the belt and now keep the glazed one as a spare.
 
1 - 7 of 7 Posts
Top