Can-Am Maverick Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
7,381 Posts
Discussion Starter #1
I need some help here….I have a SunPro MECHANICAL water temp gauge (CP8217) and I am having a hard time trying to figure out where to install the capillary tube into the engine or hoses. The spare port on the front head has a 12mm X 1.5 plug. I searched the web and couldn't locate a 12mm X 1.5 adapter fitting so I figured I would need to use some sort of inline adapter for the radiator house…..I know it can be done as I have seen these gauges used on Mavericks and Commanders….any help would be greatly appreciated.

Gauge on he right in the picture:
 

·
Registered
Joined
·
7,381 Posts
Discussion Starter #5
guys, thanks for all of the feedback but this information is for an 1/8" electronic sending unit. I have a mechanical temperature gauge with a capillary tube setup which is a 5/8" setup.. I know it has been done before because the temp gauge in the picture in the 1st post is a mechanical gauge. I would prefer to use the gauge I have as it matches the oil pressure and voltage gauges. If I have to, I will convert to an electronic gauge as a last resort but thought someone on here might have knowledge on how to do it…...
 

·
Registered
Joined
·
2,964 Posts
Here's a Commander thread that talks about it. Scroll about half way down where I go into the plug adapters you need. Gauge install tutorial - Can-Am Commander Forum

Here's the adapters. Equus 9848 - Oil Pressure & Metric Adapters Kit | O'Reilly Auto Parts
I tried Oreilly's to get my adapters. The one near me only had sae adapters, nothing in metric. As a matter of fact none of the auto parts had metric, and the offroad shop didn't have the right one. I ended up going to a hydraulic supply house. They had everything I needed.
 

·
Registered
Joined
·
7,381 Posts
Discussion Starter #7
So are you running a mechanical temp gauge? If so, did you use the spare port on the front cylinder that has the M12 X 1.5 bolt plugging it? If so, can you tell me what adapter you had to get to make it work?
 
1 - 7 of 7 Posts
Top