Can-Am Maverick Forum banner

1 - 8 of 8 Posts

·
Hickory, NC
Joined
·
2,958 Posts
Discussion Starter #1
Saw this yesterday, think I'll be adding regular hose clamps here! Anyone else seeing a leak here? Maybe just the cold garage forced it out? IDK image.jpg
 

·
Registered
Joined
·
367 Posts
In the pic I see an Oetiker clamp that is damaged. It's rolled over to the side allowing it's clamping force to be released. Oetiker clamps are those band clamps right above your leak. They actually work really well and apply even clamping force all the way around the tubing. You can get a pair of Oetiker pliers and clamps from Amazon or other tool outlets. I'll try to put a link here.
Oetiker 14100083 Side Jaw Pincers (formerly 1099): Amazon.com: Industrial & Scientific
 

·
Hickory, NC
Joined
·
2,958 Posts
Discussion Starter #3
Thanks for the link, It is coming from the "T", I'll try to get a better pic
 

·
Registered
Joined
·
367 Posts
When you've got the tool they are easier than a worm clamp to remove.
 

·
Registered
Joined
·
27 Posts
I had the same problem about a month ago, leaking at the Tee. Dealer replaced mine with worm clamps under warranty. They first tried to tighten the OEM clamps but couldn't stop the leak.
 

·
Registered
Joined
·
4,536 Posts
ya I keep an eye on my coolant connections as I have heard a few leak , just carry sum extra hose clamps on u just in case it leaks while on the trail , other wise when home just replace if u see it !
 
  • Like
Reactions: PLAY-DOH
1 - 8 of 8 Posts
Top