Can-Am Maverick Forum banner
1 - 20 of 30 Posts

·
Registered
Joined
·
290 Posts
Discussion Starter · #1 ·
So I let a buddy drive today as I was riding bitch and at about 30mph the trans jumped out of high gear. At first I thought we had blown a belt due to the rpm jump and all the noise that sounded like a belt coming apart. The shifter was fully seated in the high position detent so I don't think it was anything he did that I could tell. We had just been running ravines and there was a lot of shifting on hills (when the machine is hard to shift because of load on the driveline) do you think the shift cable stretched? I drove afterward and never had a problem? Anyone else experience this?
 

·
Registered
Joined
·
3,638 Posts
The only time I've ever had an issue with that was right before the belt blew


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
290 Posts
Discussion Starter · #3 ·
Don't say that mearsman, I just put a new one on it 100 miles ago and have been very easy on it as to not blow another one before my replacement spares arrive.
 

·
Registered
Joined
·
290 Posts
Discussion Starter · #5 ·
Secondary? Isn't that the one everyone is having problems with? I drove it another 20 miles without incident but I'll check just to be safe. Thanks
 

·
Registered
Joined
·
1,113 Posts
Adjustment may be all is needed. I've seen this a lot on quads.
 
  • Like
Reactions: mearsman

·
Registered
Joined
·
7,381 Posts
You mentioned that it was hard to shift. I had this happen to me as well when I had my belt deflection set too tight on my QSC/STM setup and it was hard to shift in and out of gears. I was riding around in low gear and then stopped really quick to drop into high to race my kid on his dirt bike and didn't take the time to give it a little gas and make surge it engaged in high before I took off. Well I got to about 45 when I realized it was still in low (gear selector was in high) and as soon as I let off the gas, it popped out of gear and you could hear it like the teeth on the gears were just catching the tips of the other gets....sounded bad. I came to a complete stop and shifted in and out of the gears a few times and made sure it engaged before taking off. It never happened again....I have since added a shim in my STM secondary and the shifting is much lighter and engages every time without any issues......
 

·
Registered
Joined
·
290 Posts
Discussion Starter · #10 ·
Is belt deflection adjustable on the stock secondary? I didn't look when I had it apart? My bad, I should know this being a snowmobiler. It's only hard to shift when I'm on a hill.
 

·
Registered
Joined
·
538 Posts
You mentioned that it was hard to shift. I had this happen to me as well when I had my belt deflection set too tight on my QSC/STM setup and it was hard to shift in and out of gears. I was riding around in low gear and then stopped really quick to drop into high to race my kid on his dirt bike and didn't take the time to give it a little gas and make surge it engaged in high before I took off. Well I got to about 45 when I realized it was still in low (gear selector was in high) and as soon as I let off the gas, it popped out of gear and you could hear it like the teeth on the gears were just catching the tips of the other gets....sounded bad. I came to a complete stop and shifted in and out of the gears a few times and made sure it engaged before taking off. It never happened again....I have since added a shim in my STM secondary and the shifting is much lighter and engages every time without any issues......
i think that is what happened to me also,sounds exactly like what i heard and it was shortly after shifting from low to high.
 

·
Registered
Joined
·
7,381 Posts
Is belt deflection adjustable on the stock secondary? I didn't look when I had it apart? My bad, I should know this being a snowmobiler. It's only hard to shift when I'm on a hill.
unfortunately not.....withthe stock setup, you have to grab the brakes while you are still moving forward. If you let it roll backwards at all and try to shift, it is really difficult...

i think that is what happened to me also,sounds exactly like what i heard and it was shortly after shifting from low to high.
yea, you have to give the gas a little blip to get it to engage before you take off. Since I loosened my deflection, it has been a non issue.
 
  • Like
Reactions: BRETT

·
Registered
Joined
·
142 Posts
You mentioned that it was hard to shift. I had this happen to me as well when I had my belt deflection set too tight on my QSC/STM setup and it was hard to shift in and out of gears. I was riding around in low gear and then stopped really quick to drop into high to race my kid on his dirt bike and didn't take the time to give it a little gas and make surge it engaged in high before I took off. Well I got to about 45 when I realized it was still in low (gear selector was in high) and as soon as I let off the gas, it popped out of gear and you could hear it like the teeth on the gears were just catching the tips of the other gets....sounded bad. I came to a complete stop and shifted in and out of the gears a few times and made sure it engaged before taking off. It never happened again....I have since added a shim in my STM secondary and the shifting is much lighter and engages every time without any issues......
The same exact thing happened to me the first time I took it out for a ride with my QSC/STM. it was a bit hard to shift. I didn't add a shim but it seems to be getting better. Assuming the belt is stretching or the clutches are breaking in. But yeah... What an awful, gut wrenching sound!!!


Sent from my iPhone using Tapatalk so please excuse my fat finger syndrome.
 

·
Registered
Joined
·
7,381 Posts
yes it is! I checked my fluids and didn't see any metal in it so I hope all is well inside the gearbox. I haven't had any problems since I installed the extra shim....
 

·
Registered
Joined
·
548 Posts
Heavy. Same exact thing happened to me too!! I was in low to climb steep incline the shifted to high at top of hill. Then i took off and a loud bang from gear box or rear end. It was awful. Me and wife looked at each other.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7,381 Posts
I hope you didn't cause any damage. The gear boxes seem to be pretty rugged....(knock on wood). Was your shifting easy or a bit hard? Mine was due ot having the belt deflection too tight....
 

·
Registered
Joined
·
6,621 Posts
Mine has been hard to shift the last few times out riding. I also notice that if I switch off my sport mode the RPM's would drop and then I could shift it into gear.
 

·
Registered
Joined
·
7,381 Posts
Mine has been hard to shift the last few times out riding. I also notice that if I switch off my sport mode the RPM's would drop and then I could shift it into gear.
you are experiencing a weak primary spring. You can cure that by installing the spacer that should have came with your QSC primary and put it under the spring and it will increase the preload on the spring and keep it from engaging to early.....either that or replace the spring.....
 

·
Registered
Joined
·
548 Posts
Heavy. My shifting is a bit hard some times, meaning it is hard for the shifter handle to be placed in gear. In fact right before mine clunked i was having a hard time getting it into H. I dont think my belt is too tight but how doo you check? Take covers off and put in N and start it to see if sec clutch creeps??


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7,381 Posts
Heavy. My shifting is a bit hard some times, meaning it is hard for the shifter handle to be placed in gear. In fact right before mine clunked i was having a hard time getting it into H. I dont think my belt is too tight but how doo you check? Take covers off and put in N and start it to see if sec clutch creeps??


Sent from my iPhone using Tapatalk
that is correct if it is a belt tension issue....but if you can tell if the primary is starting to engage while at idle then you have a weak primary spring and you either need to replace it or add the spacer that came with the QSC primary to increase the preload so it doesn't engage as soon.
 
1 - 20 of 30 Posts
Top