Can-Am Maverick Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter #1
I have the base model '13. I have the small black digital gauge. I went through the different options and only saw an odometer, trip odometer, hour meter and speedometer. Are any of you installing an aftermarket tach or just purchasing the factory tach set up?
 

·
Registered
Joined
·
6,621 Posts
The better factory gauge cluster was one of my main reasons for buying the Xrs model.
 

·
Registered
Joined
·
711 Posts
go to the odometer and press and hold the button on the right till it changes from speed to RPM

then

go back to the odometer and press and hold the button on the right till it changes again. when it changes the 2nd time it will show RPM AND speed. you'll like it much better with the RPM and speed both showing. i change every bike that comes in with that cluster
 

·
Registered
Joined
·
103 Posts
Discussion Starter #4
Oh, great. Thanks so much Airdam. I was kinda aggravated when I thought I didn't have a tach at all.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #5
Just did what you said and it is just like you said....not that I doubted you, just saying its perfect and thanks.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #7
I tried this and could not get it to work for me


Sent from my iPhone using Tapatalk - now Free
Just do exactly what he said...I even thought huh, when he said go to the odometer mode. I was thinking, did he mistype, I said I wanted RPM....hmmmm. I tried exactly what he said and it worked perfectly on the first try. Go give it another shot. Make sure you do it twice, just like he said. You will see the "MPH" at the top, just left of center disappear one of the times. Anyway, it does work. I am sure I didn't explain any better than he did...just reworded what he said. I like it so much better, so just wanted to give you reassurance that it works if done right. I probably lucked out that it worked on the first shot for me.
 
1 - 8 of 8 Posts
Top