Can-Am Maverick Forum banner
1 - 20 of 47 Posts

·
Registered
Joined
·
276 Posts
Discussion Starter · #1 ·
Its not the belt cause I changed it. It has a noticeable surge at this speed then mellows out. Been wondering what it is. Motor changes rpms and it lurches forward all the time. Does it in 4wd or 2wd inbetween that mph. Its rotational I know that.

Cant seem to figure it out
 

·
Registered
Joined
·
2,036 Posts
whos tune is it?

the ecu is very complex
it tries to predict what you are doing
so at lets say 20% throttle it gives you 25%
then you push it to 25% then the ecu gives you 40%
and may change the torque target
torque is a big combination of factors
its boost but with lots of other factors
 

·
Registered
Joined
·
276 Posts
Discussion Starter · #3 ·
Evo tune. I can give them a call and see. Pretty damn noticable I know that
 

·
Premium Member
Joined
·
2,243 Posts
Its trying to tell you not to drive it like a popo its a thoroughbred and needs to run not trot around the corral
 

·
Premium Member
Joined
·
1,514 Posts
It sounds like a lean condition. Do you have the latest/updated tune from them? They had a recall on a tune (I don’t remember which one) due to it being too lean but I don’t think it was at low loads.
 

·
Registered
Joined
·
1,393 Posts
What stage do you have and what RPM is the problem?
 

·
Premium Member
Joined
·
698 Posts
Its not the belt cause I changed it. It has a noticeable surge at this speed then mellows out. Been wondering what it is. Motor changes rpms and it lurches forward all the time. Does it in 4wd or 2wd inbetween that mph. Its rotational I know that.

Cant seem to figure it out
What tune. My 3ri does the same thing. It is to lean in the cruise areas.
 

·
Registered
Joined
·
192 Posts
They even do it stock, get yourself a wideband and see, AFR's go way rich to protect the catalyst in part throttle cruise in a certain areas.
ECM calculates EGT's and richens AFR's and pulls the timing back your feel this when timing changes and the AFR leans up. Also they probably to this in areas prone to detonation.
 

·
Registered
Joined
·
276 Posts
Discussion Starter · #9 ·
Stock tune does it to just tested. So not the tune. It really jerks when it does it. I have no cats either. I just ran a short monitor. Anyway I can look at it?
 

·
Registered
Joined
·
192 Posts
If you have a dynojet PV CX or PV3 you can watch commanded/actual AFR and Timing and see it. There is no temp sensor in the exhaust it's just a calculated EGT. So it doesn't matter if there's a cat or not, mine will command 9.5 AFR and end up at 10.1 when it goes way rich and drops the timing to around 10 also at a part throttle cruise around 30mph stock. Calculated EGT starts to hit 1830-50 when this starts to happen.
 

·
Registered
Joined
·
276 Posts
Discussion Starter · #11 ·
Ya now that I'm back home I'll try to diagnose this better. It so bad slowing down even on blacktop you can here the tires slip. You can still feel it at high mph but greatly reduced.

Checked for codes and nothing.
 

·
Registered
Joined
·
276 Posts
Discussion Starter · #12 ·
Its not the belt cause I changed it. It has a noticeable surge at this speed then mellows out. Been wondering what it is. Motor changes rpms and it lurches forward all the time. Does it in 4wd or 2wd inbetween that mph. Its rotational I know that.

Cant seem to figure it out
What tune. My 3ri does the same thing. It is to lean in the cruise areas.
I have the 3ri 93 octane tune. I've had it for a few months.
 

·
Registered
Joined
·
276 Posts
Discussion Starter · #14 ·
Checked the belt and it might be the belt. Turning the secondary theres a spot that get easy to turn. Put my spare on and did the samething and nothing.

Getting a new belt then I'll give it a run
 

·
Registered
Joined
·
1,271 Posts
I have the Evo stage one and it surges wildly around 30 MPH. I like it.
Wish it did it sooner,, like surge outta the hole shot.
 

·
Registered
Joined
·
276 Posts
Discussion Starter · #17 ·
New belt helped alot but seems to be slowly getting worse again. Im wondering maybe a weight getting stuck on the clutch????
 

·
Premium Member
Joined
·
698 Posts
when did an update come out? Lean would pop and backfire wouldn't it? I have 3r not 3ri?
Depends on how lean, and the load. Mine just surges like crazy around 4k rpm in or out of gear. Two wide band meters show AFR's in the mid 16's at that point.
 

·
Registered
Joined
·
276 Posts
Discussion Starter · #20 ·
Ya was the belt. Still surges alittle yet with a new belt but not near as bad
 
1 - 20 of 47 Posts
Top