Can-Am Maverick Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I attempted to put on my 3" lift from super atv. I began with the front but the bolt hold didn't line up, one bolt would but the other wouldn't, vica versa when tryin the other hole, has anyone else encounters this problem with this lift?? I could bore out one other holes bigger but am afraid to
 

·
Registered
Joined
·
150 Posts
No...don't bore the holes...Leave that as the very last resort !! I did... After you work it around trying to get the bolt in, where the bottom slides into the square steel hole you will see a slight scrape on the angle where it hits the top of the square tubing... I took a small grinding wheel and took abt 1/16 inch off and it fit good... that way it will slide into the square tubing deeper so the top bolts will go straight in instead of being angled... Mine on the drivers side worked good the problem was the passenger side... Like if it helps you please... :0)
 
  • Like
Reactions: Cwallace1

·
Registered
Joined
·
502 Posts
My passager side did the same....
The best part about it when I was installing the kit n ran into this problem I called SuperAtv n asked
if they have heard of the problem, they said its news to them they never heard of the passager side bracket not fitting in the frame.
i hit a big hole the week b4 bent arm n tierod so I thought it was only my machine.
Then I got on the ole forum n saw almost e-1 has the same problem....
Fix it already... N stop telling us "It's news to me"
I don't care bout lil grinding but I do care when somebody out n out knows what your talking bout n doesn't wanna admit there is a issue.
 

·
Registered
Joined
·
32 Posts
good info, I guess I'll have to find out tonight if it's all of them. mine was delivered this morning.
 

·
Registered
Joined
·
502 Posts
If it is its not to big of a deal but as C Wallace has expressed it is aggravating
 
1 - 6 of 6 Posts
Top