Can-Am Maverick Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
272 Posts
Discussion Starter #1
Does anyone know how to take primary apart to add shims under spring.
 

·
Registered
Joined
·
272 Posts
Discussion Starter #2
Ok crisis is over, got ahold of Kris at coldblooded and all is well.
 

·
Registered
Joined
·
7,381 Posts
tell us what the fix was so we all know for future reference….
 

·
Registered
Joined
·
272 Posts
Discussion Starter #4
tell us what the fix was so we all know for future reference….
My bad, it was actually very simple. I told him the machine was brand new and he said just ride it around a little and let the belt wear for bit and then see how it does. Drove it acouple miles letting it cool twice in between and it shifts in and out of gear alot better now.

My apologies on not telling what he said, felt kinda silly not thinking to do that.

Nathan
 

·
Registered
Joined
·
272 Posts
Discussion Starter #6
How do you like the rage 3 and are you running the stm secondary?
Yes sir, to be honest I haven't got to try it out much. I put 3 miles on it with factory set up and a little over 2 miles with new set up. Most I can get on my little road is 50 mph and I gets there with ease the most I could get before in same distance was a hair over 40.


 
  • Like
Reactions: maverickmn

·
Registered
Joined
·
998 Posts
well thats a big improvement, I've been thinking about going with the rage 3 or 6 but I just cant make my mind up
 

·
Registered
Joined
·
272 Posts
Discussion Starter #8
It's probably getting a little stouter as it breaks in too but I can tell its alot snappier. Just wish I'd of drove it more with the factory set up so I could have alot better comparison of the two.
 
1 - 9 of 9 Posts
Top