Can-Am Maverick Forum banner

261 - 280 of 295 Posts

·
Registered
Joined
·
294 Posts
Bringing this back up to the top. Has anyone found a fix to the slow crank when hot on the xds?
 
  • Like
Reactions: ben jantz

·
Registered
Joined
·
234 Posts
Just had my 15 xds out in the snow. This time it would not start after 1/2 hour of hard running and had to get towed home. I'm open to suggestions for this hard start issue also. Anybody?
 

·
Registered
Joined
·
88 Posts
I have to laugh, I read all the comments from 1/15 thru now. Didn’t want to miss the fix I hadn’t tried. My 15 XDS Non left me stranded with a 3 mile walk out of the woods during deer season. I was not a happy hunter. My friend left work early with a large / heavy Snap On jump pack. I met him at my truck and after a few CanAm jokes from this true RZR friend I started my journey back carrying this concrete block back to my Mav. Yes I tried it before I jumped it and OFCOURSE it started. LOL you can’t make this shit up. It has failed only once after that debacle and that was enough. I purchased a small jump pac that fits in the glove box. Problem Solved
 

·
Registered
Joined
·
88 Posts
One more thing, I pull a lot of amps with accessories including a winch, And I used the winch a lot last week on several Buggies at a wild night ride river crossing with out issues. I also run a roof system that’s flat out crazy with 8 speakers sub and amp with 40 in front curved and 12 in rear Led lightbars. Mayhem is the Mfg. I run the stock battery. I have the same slow roll during warm starts.
 

·
Registered
Joined
·
88 Posts
Any new fixes for this issue? I’m looking at a dual Odyssey’s with an isolator my jump pac idea sucks
 

·
Registered
Joined
·
12 Posts
After all the time this hot starting problem has existed, I was in hopes I could pop onto this thread and get “the fix”. My 2014 Non-turbo XDS has had the Hot start hiccup from day one. It has never not started and left me stranded, but unnerving just the same. Crazy this problem still exists. Since my old battery gave up the ghost, I just did a battery box retrofit to accept a 26R auto battery with 450 CCA in some hopes of improvement. Haven’t finished hooking up the new 26R battery yet so don’t know if it made a difference yet.

Dear BRP, note the date today January 19, “2019”! Still not fixed......REALLY!
 

·
Premium Member
Joined
·
1,638 Posts
I’ve seen a few do this. Of the 3 machines all were the fuel pump. Probably already been said though


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
349 Posts
Mine has always had the exact hard start as you guys call it......like trying to start with a dead battery......it always sounds the same and it always starts.
Not an issue.

My oem battery died on me on top of a mountain at night, I always carry a small jumpstarter/battery backup....they are the size of a large cellphone and weigh a pound or so......you should always have one......I now have an Odyessy PC1200 and it starts easy cold and struggles for a second hot......just like before
 

·
Registered
Joined
·
10 Posts
I just read thru 20 some pages and no fix. Who had an old Honda atv? Remember those with the decompression button. Almost same symptoms but worse. My 15 xds non turbo has always done this too was hoping for answers. Wondering if they shut down in the compression cycle and if you let it cool down the compression leaks out enough.

Only way to fix is higher power battery or/and higher torque starter?

Sharia lists the replacement battery as part LFX36L3-BS12 which is 540cca or twice the factory.

Looks like some have had success with higher power batteries
 

·
Registered
Joined
·
349 Posts
how is it a problem that needs to be fixed ?? a turbo xds starts slowly when warm...….how is it an issue ? unless the 5 second delay compared to a cold start is taking time out of your day ! lol......sluggish start with a start 100% of the time isn't an issue....youre just holding the button a few seconds longer than when its cold......put a diesel truck starter and dual group 35 marine batteries in it if the 5 second sluggish start is killing you !


not starting is a problem....starting the same way each time is not a problem...…..I remember those old Honda's...a few other vehicles had the decompression button also
 
  • Like
Reactions: Tmesic

·
Registered
Joined
·
10 Posts
The extra 5 seconds isn’t the problem. I also don’t think sluggish is the right word. Unless mine does something different than the others are. Mine cranks a partial rotation then stops for a couple seconds then cranks. If I could be gaurenteed that it will always start that would be fine. My fear is my battery will be a little low and it won’t be able to overcome the stalled spot.

I can’t lie it’s been doing all 3 years and still to this day if I stop somewhere on the trail, during restart I I have a small panic like oh shit
 

·
Registered
Joined
·
349 Posts
yup, thats exactly how they start......by sluggish i meant that it doesnt spin the engine over quickly trying to start when its hot......its almost like something is wrong and then it starts....everytime......always carry a tiny little jump box, they only weigh 2-3 lbs

mine definitly hangs up when starting hot........so youve been panicking for three years ?? lol stop !
 
  • Like
Reactions: BLR

·
Registered
Joined
·
1 Posts
I have been having the same type opf issue on 2018 Maverick trail 1000DPS. In January the dealer replaced the Fuel pump it ran good that day. a month later it started getting off the trailer, turned it off then it took about 10 minutes to get it started again. Took it back to the dealer, they replaced the Cam Sensor and distibuter. took it riding after picking it up ran for about 1/2 hour stopped for 5 minutes then it took another 10 minutes or so to get it to start again. The dealer says they are waiting on replies from CanAm for the next step in service.
 

·
Registered
Joined
·
88 Posts
I have installed the odyssey 935 under the drivers seat. fits nice with a brackets and a heat sinc to keep it cool. I run an isolator between both batteries. The odyssey powers the starter and winch. the stock battery powers the roof amped system and dual light bars and whips. After doing all of this..... I STILL HAVE SLOW ROLL AT START UP. LOL
Its not the battery. I also went with a larger diameter battery cables. however I haven't needed a jump since the install. Knowing what I know now, I would just upgrade the battery and be done...
 
  • Like
Reactions: Mudskipper

·
Registered
Joined
·
129 Posts
Just stumbled on this post. I have a 14 max xds and had this sluggish start. Added 2nd battery and ran all accessories off that with true am isolator. That helped for about a week then back to the sluggish starting and continues to do it. I have nothing running off the stock battery system. I have been left stranded due to this and have installed 3 batteries now in my 5 year old machine

with the odyssey or r-26 battery how much alteration is needed to be done to the battery tray?
 

·
Registered
Joined
·
3,484 Posts
I don't think anyone has been able to figure out what causes the slow start on the 15 and down Mavericks...I had both a 14 and turbo 15
Xds and both had the issue.
 

·
Registered
Joined
·
4 Posts
I figured out what causes them to roll over real slow when hot......but you are not going to like by answer. I have a 2015 maverick max 1000 turbo. I first thought the battery was bad so I started carrying a jump pack and had to use it a couple times so I went and bought a new battery. It seemed a little better but then in the middle of a ride I shut it down and it wouldn't start back up. I wore my battery and jump pack down and had to load on a trailer. Got it home and charged battery and it worked great. FRUSTRATING!!!
I took it to the dealer because I was so frustrated with it and they determined it was the starter. Something happens with it when it gets hot. The starter is buried behind everything so it was extremely expensive to replace it but I haven't had an issue since and that was about 8 months ago. Rolls over great when hot!!!
 

·
Registered
Joined
·
14 Posts
I have been having the same type opf issue on 2018 Maverick trail 1000DPS. In January the dealer replaced the Fuel pump it ran good that day. a month later it started getting off the trailer, turned it off then it took about 10 minutes to get it started again. Took it back to the dealer, they replaced the Cam Sensor and distibuter. took it riding after picking it up ran for about 1/2 hour stopped for 5 minutes then it took another 10 minutes or so to get it to start again. The dealer says they are waiting on replies from CanAm for the next step in service.
My 2018 maverick trail 1000 dps had the same problem with starting slow and finally died on the trail towed out and after testing found the starter solenoid had grounded out from a combination of mud, water and corrosion. Cleaned out the area and replaced starter solenoid, starts like brand new. The solenoid is in a bad spot under the driver's seat where it gets caked in mud and is sitting in a pocket with poor drainage, it needs little extra cleaning to keep alive longer . Hope this helps
 

·
Registered
Joined
·
7 Posts
I figured out what causes them to roll over real slow when hot......but you are not going to like by answer. I have a 2015 maverick max 1000 turbo. I first thought the battery was bad so I started carrying a jump pack and had to use it a couple times so I went and bought a new battery. It seemed a little better but then in the middle of a ride I shut it down and it wouldn't start back up. I wore my battery and jump pack down and had to load on a trailer. Got it home and charged battery and it worked great. FRUSTRATING!!!
I took it to the dealer because I was so frustrated with it and they determined it was the starter. Something happens with it when it gets hot. The starter is buried behind everything so it was extremely expensive to replace it but I haven't had an issue since and that was about 8 months ago. Rolls over great when hot!!!
Hi Mogulmasher,
my Name ist Toby from Germany and i have the hot start problem with my xds Turbo Sinne Day One i bought ist in 2015. i replaced several batteries but it is absolute frustrating. My Dealer is Not able to fix it Until today. When i Unterstand u right unreplaced the starter Right? Please if anybody knows a Solution for that issue,please let me know. My Mav let me down several times in the Place of nowhere and that is not really fun. For some mistakes in Gram or english i´m really sorry! My school english is 20 year ago 🙈.
best regards
Toby
 
261 - 280 of 295 Posts
Top