Can-Am Maverick Forum banner

1 - 20 of 288 Posts

·
Registered
Joined
·
400 Posts
Discussion Starter #1
Well my xds has been starting sluggish after its warmed up and today i went for a rip its about -5 here...shut her off and wouldn't start....had to get a boost..:crying:
 

·
Registered
Joined
·
3,454 Posts
Well my xds has been starting sluggish after its warmed up and today i went for a rip its about -5 here...shut her off and wouldn't start....had to get a boost..:crying:


Yeah these things don't start well when warm...my other Mav did the exact same thing when I first had it I just think the batteries they put in these machines are crap.
 

·
Registered
Joined
·
761 Posts
Has anyone tried a better battery yet? All my passengers look at me funny when I start this thing when its warm. Its goofy for sure..
 

·
Registered
Joined
·
1,205 Posts
Has anyone tried a better battery yet? All my passengers look at me funny when I start this thing when its warm. Its goofy for sure..
Here's your solution if you have a Max...
image.jpg
 

·
Registered
Joined
·
400 Posts
Discussion Starter #9
I do not feel that its right to have to put a better battery in at my own expense...maybe iam asking to much but i should be able to start my new $25000 buggy with the factory battery if not me and can am is gonna have long conversation.
 

·
Registered
Joined
·
3,454 Posts
I do not feel that its right to have to put a better battery in at my own expense...maybe iam asking to much but i should be able to start my new $25000 buggy with the factory battery if not me and can am is gonna have long conversation.

I agree it isn't right and going for a better battery may be an up hill battle but worth going for IMO...I'll be hitting Adventure Motors with the same issue

this week when I take my machine there to get the oil line replaced.
 

·
Administrator
Joined
·
2,299 Posts
Will be great to find out....to me, the symptoms aren't pointing towards a battery, but one with more cranking amps definitely will help....just need to decipher if it is the cure or just a coverup bandaid.
 

·
Registered
Joined
·
5,670 Posts
I would also check all ground connections and the connection at the starter.
 

·
Registered
Joined
·
3,454 Posts
Does anyone with xds turbo not have this issue and any non-turbos have it? My turbo does the same--scared to us any accessory (lights, stereo) that pull the battery more.


Most of the Turbo's on here have had slow starting issues including mine and yes I believe the 13 and 14 Mavs had it too at least mine did but not as bad as my Turbo

this shouldn't be happening on such an expensive machine IMO...makes me wonder when they BRP does all this so called testing a year or so in advance of the production

model why they wouldn't come across these issues and if they did fix the damn thing.
 

·
Registered
Joined
·
1,452 Posts
Does anyone with xds turbo not have this issue and any non-turbos have it? My turbo does the same--scared to us any accessory (lights, stereo) that pull the battery more.

My T-Max didn't seem to have this problem, but I'd still be hesitant adding accessories until I upgrade. I'd like to upgrade the battery under the rear seat to a odyssey or lithium and add a 2nd battery under the hood....Someone should come out with a battery/storage combo for under the hood....Plenty of room.

If anyone is listening I'll but one....
 

·
Registered
Joined
·
3,454 Posts
My T-Max didn't seem to have this problem, but I'd still be hesitant adding accessories until I upgrade. I'd like to upgrade the battery under the rear seat to a odyssey or lithium and add a 2nd battery under the hood....Someone should come out with a battery/storage combo for under the hood....Plenty of room.

If anyone is listening I'll but one....

Your lucky a lot on here had slow start issues with their T mavs.
 
1 - 20 of 288 Posts
Top