Can-Am Maverick Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
1,298 Posts
Discussion Starter #1
ok, I know, pictures or it don't exist, so lets say it don't exist, so what is your thoughts on why a mav -2 seater would do 75mph top speed now for 38 hrs, then all of sudden for no reason or change, start doing 78 by gps confirmed. friends did this. he has done a lot of speed testing using gps in the same area, had the 12 hr service done, so that is not the reason, 38 hrs now. 100 % bone stock, always test it between 4 and 5 bars. I don't have a clue on that, any thoughts?
 

·
Registered
Joined
·
410 Posts
I know that my garmin is always exactly 3mph slower than the speedo on my Mav.
 

·
Registered
Joined
·
6,621 Posts
Maybe it's finally broken in and has loosened up. My grand Cherokee has just past 8k miles and all of a sudden it's getting 2 mpg more .
 

·
Registered
Joined
·
998 Posts
150hrs on mine and 76-77 mph on the speedo.. Been the same since I bought it
 

·
Registered
Joined
·
4,536 Posts
22 hours on machine , I was at 7000ft , and hit 77
 

·
Registered
Joined
·
1,272 Posts
Mine does 76-77 with the dalton kit, but before the dalton kit when canam had my dealer try an EPI secondary spring, it would do 79 wtf
 

·
Registered
Joined
·
32 Posts
They have a break in chip in them! Everything BRP has one, After so many hours the chip burns out and allows you to run max RPM on the machine.
 

·
Registered
Joined
·
7,381 Posts
They have a break in chip in them! Everything BRP has one, After so many hours the chip burns out and allows you to run max RPM on the machine.
Welcome to the forum.....do you have any data or proof to back up this claim?The guys commenting on loosing top speed are not seeing a drop in RPM but top speed only.
 

·
Registered
Joined
·
32 Posts
The chip regulates the amount of power the motor produces and the top speed until the breakin period is complete. Any good mechanic or dealer will tell u about it. ill see if I can find the article I found it in and post it on here. Jst picked up my maverick Monday and love it so far, all stock now but mods coming soon. 74 MPH top speed rite now still in the breakin period lol. and thankyou for the welcome!
 

·
Registered
Joined
·
671 Posts
There is no "break in chip" in them. That is just a silly rumor. Mine has done 78 mph since day one. My best guess is tire pressures. That can really make a difference on top speed.
 

·
Registered
Joined
·
671 Posts
Correct. Higher tire pressure = less rolling resistance which increases top speed. The converse is true for less tire pressures. If you have a place to try it out do it.
 

·
Registered
Joined
·
7,381 Posts
Uh huh...and I was the shooter on the grassy knoll...next to 3 martians. ;)
I am with you on this one.....mine performs the same now as it did new and when it had the 10 hour service.....I guess my "Chip" was burned out when I bought mine....damn cheap Chinese chips :saint:
 

·
Registered
Joined
·
698 Posts
There actually is a tune on all can am and there sleds do the same thing. It detunes the motor until a certain hour meter or certain amount I liters of gas are ran through the system . Google it guys . A friend of mine owns a shop here and he told me the same thing . They been doing it on there sleds for quite a wile now .
 

·
Registered
Joined
·
502 Posts
Definitely No chip, my dealer didn't tell me bout the ten hr break in period n even if he did it wouldn't of mattered. (They told me the same thing bout my Ford when I bought it. Break it in nicely they said, I broke it in alright I broke it in just like I drive it today pretty hard but it got 263000mi now n stronger than ever. )Anyways back to the subject my dealer didn't tell me n I picked it up on the way out to the mud hole all weekend long 78 miles an hour. A buddy of mine that we met there for the weekend owns a atv/utv shop n could not believe it would do 78 so all weekend he wanted me to show people it would do 78. Of corse I was only one of two mavericks out there that weekend so I had to race Everybody n I did n I beat them Everytime but there machines were set up for mud n mud only mine was stock All I'm saying is rite outta the box mine did 78 but then I took it in for the ten hr service now I'm at 75 maybe
 

·
Registered
Joined
·
278 Posts
top speed seems to vary on these machines, maybe differences in factory clutch springs? or clutch alignment? i have a 2013 that no matter what, from the day it was new will only do 72-73mph on speedo. it has done this speed from day one and still does at 1000 miles... my buddies machine when it was new would do 76-77mph with same accessories, same air pressure in tires, same everything. as his belt wore, his speed dropped to 72, put a new belt in it and back to 77. my new 2014 has done 74-75 mph from the day it was new and not changed.
 
1 - 20 of 22 Posts
Top