Can-Am Maverick Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
998 Posts
Mine has the slippery washers from the factory, well according to my stealerships anyway. So far I have 300 miles and 200 of them I would say has been run pretty hard.
 

·
Registered
Joined
·
998 Posts
Yes, in the perfect world the primary will slip on the bolt without further tightening the bolt. Some have still broke the so called fix. Just thinking out loud but if the dealership does the clutch bolt recall and just throws a big impact on the primary bolt and torques it down he may be over tightening the bolt and not allowing the slippery washers to do there job.
 

·
Registered
Joined
·
998 Posts
Agreed, maybe that's why we haven't seen a later production model break a primary bolt to my knowledge. All the ones that have broke has been dealer installed unless I missed one
 

·
Registered
Joined
·
998 Posts
I flogged mine for 230 miles the past 3 days and I haven't had any issues other than my belt getting wet after hitting a creek a little to hard. That puts mine at 500 miles with no clutch/belt problems.
 

·
Registered
Joined
·
998 Posts
Yes, put 93 in it. You should never run anything other than premium in a high compression motor such as the mavs, it does have knock sensors and it will pull timing to keep the motor from detonating and possibly blowing it up.
 

·
Registered
Joined
·
998 Posts
Can am is "supposedly" coming out with a new fix, but once my warranty is up ill probably go full STM and not worry about it anymore
 
1 - 6 of 6 Posts
Top