Can-Am Maverick Forum banner
1 - 11 of 11 Posts

· Registered
Joined
·
230 Posts
Discussion Starter · #1 · (Edited)
Ok, Did I f this up or is this what happens.

Installed EPI Trail kit . Weights,springs,belt.

Torqued primary to 90ft/pnds, used blue loctite.

Electric rattle gun on secondary bolt, used blue loctite .

Used original secondary bolt.

Machine had done around 11hrs.

About 3 hrs of full on trail riding , nothing unusual,slowed to a halt, went to take off ,nothing.

On inspection,bolt simply backed out, not tight enough?

Covers fkd,helix is fkd,belts fkd,not sure whether to replace the bushings inside the sheeves.

What to do on replacement?

I've heard so many different ways, don't know what procedure to use?

This is how it was under the cover

Sent from my iPad using Tapatalk HD
 

Attachments

· Registered
Joined
·
230 Posts
Discussion Starter · #3 ·
Yep, I did remove secondary bolt to fit EPI spring and belt.


Sent from my iPad using Tapatalk HD
 

· Registered
Joined
·
230 Posts
Discussion Starter · #6 ·
Ok cool thx guys, yep sounds like your right, second hand bolt and guesstimate torquing. Expensive mistake.
I found it hard to lock the secondary up to tension the bolt,hence rattle gun.
Suppose I should buy the holding tool.$$$.


Sent from my iPad using Tapatalk HD
 

· Registered
Joined
·
230 Posts
Discussion Starter · #11 ·
Thx for the advice warlock, good call !

I'll get a new secondary bolt to be sure.

I will upgrade to QSC/STM later in the year,will just have to learn to dial it in myself since there's no help in Australia .

Glad I have this forum for help , I'll be competing in the local short course event in March and I need this machine to hold together,especially since it has sponsorship by a popo dealer. Track is sandy/ grassy,mostly high speed ,not sure whether to race in 4x4 or 2x4.
Test and tune on the track in 3 weeks so I'll try both I guess.

Cheers.


Sent from my iPad using Tapatalk HD
 

· Registered
Joined
·
230 Posts
Discussion Starter · #13 ·
No, my primary is not stud type,which concerns me,I hear there is the recall on it,
I'd like to just install one myself ,Are people still getting primary slip with the stud?


Sent from my iPad using Tapatalk HD
 

· Registered
Joined
·
230 Posts
Discussion Starter · #16 ·
If I go QSC , is a stud provided in the kit?


Sent from my iPad using Tapatalk HD
 

· Registered
Joined
·
230 Posts
Discussion Starter · #20 ·
Ok,noted.
Who do you recommend to get the QSC/STM from?
Do they come setup pretty close to the mark,if correct info of mods are given?


Sent from my iPad using Tapatalk HD
 

· Registered
Joined
·
230 Posts
Discussion Starter · #22 ·
Awesome, cheers,will do.


Sent from my iPad using Tapatalk HD
 

· Registered
Joined
·
230 Posts
Discussion Starter · #24 ·
Thx Trev will do,what part of oz you from ,I'm in Brisbane.


Sent from my iPad using Tapatalk HD
 

· Registered
Joined
·
230 Posts
Discussion Starter · #26 ·
So I'm just waiting for kris to get back to me about which setup to use,

Qsc/stm

Stm rage3/stm

I will be competing the car and upping the rev limit eventually.

Don't really want an over complicated setup.

Thoughts,experiences??

Cheers.


Sent from my iPad using Tapatalk HD
 

· Registered
Joined
·
230 Posts
Discussion Starter · #27 ·
Stm rage3 and stm ordered, thx Kris.


Sent from my iPad using Tapatalk HD
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top