Can-Am Maverick Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
531 Posts
Discussion Starter #1
I just wanted to share my experience with safeglo whips. When I started putting my X3 together I selected the 4' white LED safeglo whips mainly due to the pushbutton quick release mounts. The first ride out I noticed they were flickering. I contacted safeglo and they told me they revised the design and now transfer 12vdc thru a wire and plug and to send them back for warranty. I packaged them up and sent them in, they called when they received them so I thought everything was going smooth. They called Friday and said everything was done and asked me for a credit card for the repairs. I asked why they are charging me for repairs on a design flaw and was told they had to replace a couple LEDs and one of the QDs was clicking so they replace that as well. I said the whips have no more than 50 miles and all should be covered under warranty but whatever. I'm prepping for a trip and need them back.
So in all, I'm $400 into whips/shipping, shipping to safeglo, repairs/shipping back to me and they have 50 miles. I hope I get more than 50 miles this time around. Lol
Now there's 2 whip manufactures I'll never buy from again.

Sent from my ONEPLUS A6003 using Tapatalk
 

·
Registered
Joined
·
8,568 Posts
Ouch! Did you purchase the whip more than 6 months ago? Their warranty is only 6 months from date of purchase, per the website.

I ran a Safeglo whip for 4 years with no issue on my XP1000. I currently run Whiptech on my X3 and have no complaints. It comes with a remote to turn it off and on and so you can change the light colors and pattern.
 

·
Premium Member
Joined
·
6,463 Posts
I just cant understand why so many whip companies have issues with whips.

I have had several different brands and they all seem to have issues in a relatively short time.

I don't blame you for being upset and expecting they would make it right.

Tim
 

·
Registered
Joined
·
531 Posts
Discussion Starter #5
Ouch! Did you purchase the whip more than 6 months ago? Their warranty is only 6 months from date of purchase, per the website.

I ran a Safeglo whip for 4 years with no issue on my XP1000. I currently run Whiptech on my X3 and have no complaints. It comes with a remote to turn it off and on and so you can change the light colors and pattern.
Yeah, it's likely been more than 6 months so that's likely the issue with the payment and I'm fine with that. I'm more upset that they needed LEDs and a QD replaced in the limited use they've seen plus the 3 shipping charges to get them, send them and receive them. They would make a great daytime whip due to the slick mounting design I guess. Lol

Sent from my ONEPLUS A6003 using Tapatalk
 

·
Registered
Joined
·
531 Posts
Discussion Starter #6 (Edited)
Who’s the other company?
No reason to trash them on here because they do have excellent warranty and customer service, just lousy product. I'll PM ya.

Other company goes out of their way to take care of you but it's like the AutoZone ford starter with the lifetime warranty... Eventually you get sick of replacing your starter. Lol

Sent from my ONEPLUS A6003 using Tapatalk
 

·
Registered
Joined
·
67 Posts
I have 2 - 20 inch & 2 - 36 inch for my car and also 2 boat whips for the boat they all work great

I had to warranty one 36inch whip due to hitting a tree branch @ 45 mph it also tweaked the mount!
Sent it in and got it back and now they work AWESOME!

The 20 inch stubbies work perfect for the Havasu trees branches as they slide right underneath!
 

·
Registered
Joined
·
531 Posts
Discussion Starter #8
I have 2 - 20 inch & 2 - 36 inch for my car and also 2 boat whips for the boat they all work great

I had to warranty one 36inch whip due to hitting a tree branch @ 45 mph it also tweaked the mount!
Sent it in and got it back and now they work AWESOME!

The 20 inch stubbies work perfect for the Havasu trees branches as they slide right underneath!
Glad you are having good luck with yours. Are they the push button with billet quick release that uses the RCA connector to supply power or are they the revised version with a power wore you plug in?

Sent from my ONEPLUS A6003 using Tapatalk
 

·
Premium Member
Joined
·
8,996 Posts
I would definitely recommend one of our Supporting Vendors, Tribal Whips. I've run them on every car I've had, bright or brighter than anything out there, and outstanding customer service.
 

·
Vendor
Joined
·
357 Posts
Sorry I thought that was in a PM. Didn’t mean to post that... Didn’t mean to randomly answer someone else’s question.
 

·
Registered
Joined
·
67 Posts
My boat whip was a push button, quick release and while I had my stereo done the shop Swapped out my whips for the new style. My boat whips were brand new. Part of the boat stereo install was hooking up the boat whips on my rear ski bar.

My can am whips are a screw in type, with a remote control.
 

·
Registered
Joined
·
531 Posts
Discussion Starter #14
Sorry I thought that was in a PM. Didn’t mean to post that... Didn’t mean to randomly answer someone else’s question.
No hay problema, mi post es su post... Sorry, couldn't resist

Sent from my ONEPLUS A6003 using Tapatalk
 

·
Registered
Joined
·
255 Posts
I made my own after the whole venom company bs. Used I think 96 led per meter. Came out really nice but my soldering skills are subpar so the contacts kept breaking. Still use them today.
 

·
Vendor
Joined
·
357 Posts
Really like the magnetic base design. The quick disconnect that I have now gets sand it. Pain to keep clean so they release easily.
Yeah it’s a really nice fit between the sleeve and the whip light base too. Doesn’t leave any room for stuff to get in it. It also comes with rubber caps for BOTH the sleeves and the whip light bases. Great storing them and keeping them clean.
 

·
Registered
Joined
·
117 Posts
Yeah it’s a really nice fit between the sleeve and the whip light base too. Doesn’t leave any room for stuff to get in it. It also comes with rubber caps for BOTH the sleeves and the whip light bases. Great storing them and keeping them clean.
Tight enough to make a suction sound when removing them. I didn't get the caps though......hmmm.
 

·
Registered
Joined
·
2,234 Posts
Switched from Safeglo to Tribal Whips Auroras two cars ago and will never go back. Tribal has been bulletproof here at the Oregon dunes constantly banging off tree branches where as my Safeglo whips had to be sent back multiple times.
 
1 - 20 of 25 Posts
Top