Can-Am Maverick Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,128 Posts
Discussion Starter #1
Anyone installed the Can-Am factory rear bumper? I see that it's attached using the rear A-arm mounting bolts. Just wondering how much trouble to expect if I install myself...
 

·
Registered
Joined
·
7,381 Posts
I haven't installed the rear bumper but I did install the BRP rear receiver hitch which also uses the A-arm bolts. It wasn't that hard but it would have been a lot easier if the wheels where off when I did it to take some of the load off of them. Don't forget to jack it up before you pull the bolts….:smile:
 

·
Registered
Joined
·
292 Posts
I installed it and the the first thing I did was turn the bolts around so that the nuts were on the outside. Take the nuts off all 4 bolts, then jack up the frame slowly until you can pull a bolt out. Install bolt the opposite way it cam out and repeat for the rest of them. Now place bumper , line up with bolts and install nuts. It only took 10-15 minutes to do it. The biggest pain is where the upper arms of the bumper mount to the frame above the exhaust. Its tight and the bolts are barely long enough to get the thread started for the bar clamps. Oh yea the nuts are put in loose in the back of the bar clamp and you can't get your finger in there to hold them from falling out while you try to get a bolt started.
 

·
Registered
Joined
·
1,128 Posts
Discussion Starter #4
Thanks for the info guys. Looks like it won't be as bad as I thought. I'll probably put Two Bros pipes on at the same time....
 
1 - 4 of 4 Posts
Top