Can-Am Maverick Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
1,059 Posts
Discussion Starter #1
Need a little diagnostic help.

I have a 14 Max - see signature on setup - around 400 miles.

On my last ride when the suspension would cycle a single clank would come from what sounded like the left rear. Speed didn't matter, the only thing consistent is the suspension would have to be flexing or cycling. When I first heard it I immediately thought rear axle is starting to go bad, but quickly decided that wasn't it. I took it to dealer, they don't really have an area to test and weren't able to duplicate the sound. They did feel like it was definitely not the axle. Visually there is no indication of any issue.

Any ideas??

Thanks guys.
 

·
Registered
Joined
·
7,381 Posts
I would check all of the rear suspension mounting points to make sure everything is tightened to spec.....
 

·
Registered
Joined
·
1,059 Posts
Discussion Starter #3
I would check all of the rear suspension mounting points to make sure everything is tightened to spec.....
We inspected those. Everything looked good, but I am going to double check today and put a wrench on it. Tomorrow my Racertech spring get here so I will have everything apart.

The only part I am wondering now is the sway bar link. Visually it looks completely normal. How would I know if it was failing?
 

·
Registered
Joined
·
274 Posts
Jack the rear end up, remove shock and cycle suspension up and down manually and see if you can reproduce the noise?
 

·
Registered
Joined
·
4,535 Posts
push ur maverick side to side at the back and u will hear the sway bar end links click knock tap what ever u wanna call it , see if that's the sounds
 

·
Registered
Joined
·
119 Posts
My rollcage bolts were loose on the bottom of the pillar right behind the driver. I swore it was coming from the rearend
 

·
Registered
Joined
·
7,381 Posts
good call CrazyCooter....
 

·
Registered
Joined
·
1,059 Posts
Discussion Starter #9
push ur maverick side to side at the back and u will hear the sway bar end links click knock tap what ever u wanna call it , see if that's the sounds
Did this and heard what your talking about but still not it.
 

·
Registered
Joined
·
1,059 Posts
Discussion Starter #10

·
Registered
Joined
·
7,381 Posts
is it load enough to record a sound clip so we can hear it....
 

·
Registered
Joined
·
1,059 Posts
Discussion Starter #13
No I haven't. I am thinking it must be the sway bar. It is just so random it is nearly impossible to track down.

It isn't the cage mounts or anything else mentioned prior. Although I thought for sure that's what it was going to be.
 

·
Registered
Joined
·
12 Posts
We went out this last Sunday and I had a metallic clank only when the suspension cycled. It was driving us crazy. I actually heard it the week before and found the rear upper control arm bushings trashed. I was sure that was it. I installed new bushings which leaves me to this last ride where the same noise was still present. Wouldn't do it on right hand corners but on straight away and definitely left hand corners as the suspension cycled. I couldn't pinpoint it so I had the wife drive while I jumped in the back seat just behind the driver. It didn't take long to find the noise. It was the cage mount behind the driver's seat down at the floorboard. There is a rubber plug that I removed. I think it is like an 8mm allen. I didn't have the right tool on the trail but found a standard screwdriver that worked until I got home to torque it tight. It got rid of that clunk.
 

·
Registered
Joined
·
7,381 Posts
We went out this last Sunday and I had a metallic clank only when the suspension cycled. It was driving us crazy. I actually heard it the week before and found the rear upper control arm bushings trashed. I was sure that was it. I installed new bushings which leaves me to this last ride where the same noise was still present. Wouldn't do it on right hand corners but on straight away and definitely left hand corners as the suspension cycled. I couldn't pinpoint it so I had the wife drive while I jumped in the back seat just behind the driver. It didn't take long to find the noise. It was the cage mount behind the driver's seat down at the floorboard. There is a rubber plug that I removed. I think it is like an 8mm allen. I didn't have the right tool on the trail but found a standard screwdriver that worked until I got home to torque it tight. It got rid of that clunk.
good deal...thanks for letting us know.
 

·
Registered
Joined
·
119 Posts
We went out this last Sunday and I had a metallic clank only when the suspension cycled. It was driving us crazy. I actually heard it the week before and found the rear upper control arm bushings trashed. I was sure that was it. I installed new bushings which leaves me to this last ride where the same noise was still present. Wouldn't do it on right hand corners but on straight away and definitely left hand corners as the suspension cycled. I couldn't pinpoint it so I had the wife drive while I jumped in the back seat just behind the driver. It didn't take long to find the noise. It was the cage mount behind the driver's seat down at the floorboard. There is a rubber plug that I removed. I think it is like an 8mm allen. I didn't have the right tool on the trail but found a standard screwdriver that worked until I got home to torque it tight. It got rid of that clunk.
That's exactly where mine was
 

·
Registered
Joined
·
25 Posts
I had sane issue several bolts dealer didn't fully tighten wasn't very happy about it, had 2 areas on roll bar whet nuts and bolts were missing


Sent from my iPhone using Off-Road Forums
 

·
Registered
Joined
·
368 Posts
Just brought mine home today..think I'll give it a good going over tomorrow.....

Sent from my SM-N900V using Tapatalk
 
1 - 20 of 25 Posts
Top