Can-Am Maverick Forum banner
1 - 20 of 45 Posts

·
Registered
Joined
·
82 Posts
I have the same rattle. With everyone clutch issues I'm just waiting on mine to explode. Lol. But haven't tried to trace mine either. Will do soon though.
I also already had both exhaust bolts(spring one) back completely out on the first ride.
I only found one and had to make something for the other side.
 

·
Registered
Joined
·
232 Posts
Mine does too. Had it back to the dealer during the 10 hr service and they pinpointed it to the intake specifically the diverter. Replaced the intake with another, but only changed the RPM range of the vibration rattle. To be honest, I have gotten used to it.
 

·
Registered
Joined
·
4,535 Posts
i fixed my rattle problems with a rugged radio !!

sounds great
 

·
Registered
Joined
·
6,621 Posts
Mine has had it from the beginning. Mine sounds like its coming from up front but not 100% sure. I just mash the pedal a little more and away it goes!
 

·
Registered
Joined
·
104 Posts
Mine has had it from the beginning. Mine sounds like its coming from up front but not 100% sure. I just mash the pedal a little more and away it goes!

Mines is the same way. Sounds like its something up front. I think its somewhere above my feet. Rattles I can deal. It will just take me a little time to find it. But no worries. The smile it puts on our face is worth a little rattle.
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #19 ·
talked to my dealer today he said they had some trouble with the exhaust springs on the commander?? anybody ? how did you or how can we quiet them down???
 
1 - 20 of 45 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top