Can-Am Maverick Forum banner
21 - 40 of 44 Posts

·
Registered
Joined
·
7,381 Posts
So for the QSC and STM bolts I can reuse, brilliant.

Last question would you put blue lock tight on them or not needed. The dealer did not put any on.


Sent from my iPad using Tapatalk HD
It wouldn't hurt but it will burn off of the primary due to the heat. I personally don't use it because QSC and STM did not call for it in their installation instructions…..
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #22 ·
Well talked to ppl and they said to try a 40 helix over my 50/40 and got suggested 2 1/4 set in cross , base empty, 1/4 allen in center and 1/4 set in tip, see how it works and let you know, im thinking its still going to have overrev
 

·
Registered
Joined
·
7,381 Posts
I would suggest starting with just the helix first and test it. This will give you an idea of how it affected everything. Then go and make your weight changes......
 

·
Registered
Joined
·
394 Posts
Good advice. One change at a time and write down each weight change and the results in case you need to fall back on a good combo.
 

·
Registered
Joined
·
7,381 Posts
It really helps you learn how to do your own tuning as well. You will see first hand what affect each adjustment has so you know later on.
 

·
Registered
Joined
·
78 Posts
Clutch in gear
What do you think does it look good, installed the shim on QSC to raise rpm engage.


Sent from my iPad using Tapatalk HD
 

·
Registered
Joined
·
92 Posts
Ive been tuning my here lately and I just about got it dialed in. 3/8 cross 1/4 base, middle empty, and 1/4 tip. I also had to add another shim to primary to bring my engagement up to 2100 rpm and switched the secondary spring to a gold. Im seeing 7850 rpm from dead stop to about 40 mph and then it hits 8000 rpm until 68, then drops down to 7400 rpm and climbs back to 8000 rpm at 78 mph. im pretty happy with it except the drop on top end. But I don't run that fast very often, so its not that big of deal to me. good luck, just start tuning. you will eventually find what works. oh yeah, im running a 40 straight helix
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #29 ·
on your primary are those set screws or allen bolts

Ive been tuning my here lately and I just about got it dialed in. 3/8 cross 1/4 base, middle empty, and 1/4 tip. I also had to add another shim to primary to bring my engagement up to 2100 rpm and switched the secondary spring to a gold. Im seeing 7850 rpm from dead stop to about 40 mph and then it hits 8000 rpm until 68, then drops down to 7400 rpm and climbs back to 8000 rpm at 78 mph. im pretty happy with it except the drop on top end. But I don't run that fast very often, so its not that big of deal to me. good luck, just start tuning. you will eventually find what works. oh yeah, im running a 40 straight helix
Those set screws or Allen bolts.
 

·
Registered
Joined
·
7,381 Posts
honestly, i don't think it is supposed to spin so freely at idle. Mine creeps a bit but yours is at a full spin. Maybe ask Kris what he thinks….maybe mine is too loose because yours doesn't creap while in gear….
 

·
Registered
Joined
·
394 Posts
I'm with heavy. You might have trouble getting it in and out of gear. It should't spin at idle.
 

·
Registered
Joined
·
78 Posts
Went for a extended ride this evening, shifting between gears are smooth. Clutches engaging at about 2000 rpm. All good. Will go for a ride again in the morning.

Kris from CBP had a look at the videos and seemed happy.


Sent from my iPad using Tapatalk HD
 

·
Registered
Joined
·
7,381 Posts
Went for a extended ride this evening, shifting between gears are smooth. Clutches engaging at about 2000 rpm. All good. Will go for a ride again in the morning.

Kris from CBP had a look at the videos and seemed happy.


Sent from my iPad using Tapatalk HD
Interesting.....I wonder if mine are too loose as mine don't spin like that in Park or Neutral....
 

·
Registered
Joined
·
78 Posts

Vid shows the clutches while in park, then in R and back to park.
Shim to increase engage rpm installed on QSC and 2 fibre washers on STM to control belt height.
Kris seemed happy with the setup.

Post a vid of yours

Sent from my iPad using Tapatalk HD
 

·
Registered
Joined
·
7,381 Posts
What is making that noise when it starts to freewheel in Park? Is it coming from the belt or the clutches?
 

·
Registered
Joined
·
7,381 Posts
Part of the setup it ensure it doesn't creep while in gear....yours obviously isn't doing that. But it also says to ensure it isn't squealing at idle. I almost wonder if you belt is a little to tight and that is what we are hearing from the primary clutch.....
 

·
Registered
Joined
·
78 Posts
Good point, I will open it up again after tomorrow's ride and recheck, the STM has the 2 washers in and the belt does not look to tight, it is a brand new belt.

Will report back when I have it open again. What is the suggested solution, adding one more washer on the STM?


Sent from my iPad using Tapatalk HD
 

·
Registered
Joined
·
7,381 Posts
I would hate to tell you to add a fiber washer if Kris said it looked OK. I was just stating mine looked different. Here is mine with the OEM belt and a brand new Gates C12 belt…..All video was with it in Park.

 
21 - 40 of 44 Posts
Top