Can-Am Maverick Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
322 Posts
Discussion Starter #1
Anyone installed one of these? Do you have a picture of what your finished installation looks like? The clamps on mine don't want to fit over the stock cage without tearing all the powder coat off of it, and apparently you can't run the rear net with these...which seems obvious now, but not at all before the bar arrived....

Let me know if you have a picture of the pro armor bar installed, I've seen the other companys but not this one and mine seems very awkward to fit in there.

JC
 

·
Registered
Joined
·
322 Posts
Discussion Starter #3
I have no idea how that could help. The clamps that came with it don't fit over the stock cage, not that the bar doesn't fit between them.

Loosen all the bolts that hold your cage together at the top. That will help you out drastically!
 

·
Registered
Joined
·
2,964 Posts
I have a UTVinc Harness bar. It was a bitch to get on as well. I had to get some longer bolts to get the clamps started, and do a little pounding with a rubber mallet. Just make sure you get it positioned exactly where you want it before you get the clamps started. Mine didn't scrape the powder coat off, but it did mash it down smooth.
 

·
Registered
Joined
·
707 Posts
I have a UTV Inc bar as well. I tried to put it on and was certain they sent me the wrong bar. I called them and they said to loosen up the bolts. I did just that and it worked just as they said it would.
 

·
Registered
Joined
·
42 Posts
maybe i just got lucky, but mine (pro-armor) was an easy install, but i could've done it wrong too :) here are pics... notice the angled alignment on the ends of your bar.
IMG_1708.jpg
IMG_1709.jpg
IMG_1710.jpg
 

·
Registered
Joined
·
322 Posts
Discussion Starter #7
Thanks for the pics. I got it installed. Definately disappointed in the "powder coat" that is all flaking off and was mostly missing on the clamps when they arrived. Got he harnesses installed and my wife hates them, so that's awesome too.
 

·
Registered
Joined
·
42 Posts
yes, the coating sucks bad! mine were the same, most missing before i even took them out of the plastic. makes me glad i got blingstar doors over theirs. your wife will be happy to wear them if an accident ever occurs!
 

·
Registered
Joined
·
42 Posts
havent installed the harnesses yet. and, i only got 3" 4pt... can you post a pic of your harnesses and how you mounted them?
 

·
Registered
Joined
·
322 Posts
Discussion Starter #11
I don't have any pics of them, but the rears just wrap around the bar, the sides re-use the stock seatbelt mounting points, or at least I did. The sub strap is where I'm not sure about. there is a metal plate in front of the seat with plastic covering it. I used that for now, probably going to stay there.
 

·
Registered
Joined
·
2,964 Posts

·
Registered
Joined
·
322 Posts
Discussion Starter #13
I tried putting mine on that bolt but I couldn't get the seat to "seat" into that cradle with it on there.. I don't hate my solution
 

·
Registered
Joined
·
81 Posts
Anyone installed one of these? Do you have a picture of what your finished installation looks like? The clamps on mine don't want to fit over the stock cage without tearing all the powder coat off of it, and apparently you can't run the rear net with these...which seems obvious now, but not at all before the bar arrived....

Let me know if you have a picture of the pro armor bar installed, I've seen the other companys but not this one and mine seems very awkward to fit in there.

JC
Is it just the Pro Armor harness bar that will not allow the use of a rear net? I have the rear net and was planning to add a 5 point harness setup.
 

·
Registered
Joined
·
1,255 Posts
I just seen over on post under what have you done to your Maverick today that a guy has the rear screen and bar, Looks like he went through the screen. I'm wondering about this also.
 

·
Registered
Joined
·
59 Posts
I have my own harness bar I welded in and I added the net last weekend. I cut a really wide "H" cut for each set of harnesses to go through. That way the harnesses can move up or down the amount I cut the net and not be in a bind. I also used a lighter on the edge where I cut it to melt any frays. I will pull it off and stitch it if it starts to tear, but I rode some yesterday and the harness didn't bother the net at all.
 

·
Registered
Joined
·
1,255 Posts
I was thinking of a reverse mount using front pillar instead of second. That way it might be on right in front of net. Another thought is where it's solid behind the set is that all black piece. Cut an opening in there and have it stiched around the cut to prevent fraying or ripping.
 
1 - 19 of 19 Posts
Top