Can-Am Maverick Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I get these error codes when 3/4-full throttle only
Stock 2019 Xmr turbo 120
I’ve read every other P0301-P0303 error code thread
Waiting on new spark plugs from evo to change them out
Just trying to check if I could come up with another solution while waiting
 

·
Registered
Joined
·
1,478 Posts
how old were the plugs (miles)
how is your fuel old? from what station
what octane was it supposed to be
my point is that crap gas can cause the misfire
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
I have about 300 miles on it
I’ve had it just over 6months
I just refueled with 93 octane and I did it this morning but the bad gas wouldn’t be out of it yet
 

·
Premium Member
Joined
·
1,611 Posts
I got ahold of bad gas about a month ago . 3/4 throttle and it would go into limp mode misfire codes. Drained the brand new gas I put in it and put new in and after a mile or so problem solved. Check your gas


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
Mine still does it sparingly
Gas seems to be a factor
I’d check ignition plugs; sparks plugs
Make sure it’s getting gas okay
Make sure your connections at battery and solenoid are tight
There’s a fuel line tube under the center console
Zip ties on the rear line
 

·
Registered
Joined
·
48 Posts
Mine still does it sparingly
Gas seems to be a factor
I’d check ignition plugs; sparks plugs
Make sure it’s getting gas okay
Make sure your connections at battery and solenoid are tight
There’s a fuel line tube under the center console
Zip ties on the rear line
Yeah I fueled up right before it started giving me problems
 
1 - 8 of 8 Posts
Top