Can-Am Maverick Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2,963 Posts
Discussion Starter #1 (Edited)
Where are you guys putting the sending unit for an electrical oil pressure guage?

Found my oil psi guage this evening...:big smile: now I just need to hook it up

 

·
Registered
Joined
·
2,963 Posts
Discussion Starter #2 (Edited)
Is this the OEM oil pressure sending unit? It looks like a sending unit. IF so can I just tap in to the blue wire? or are you putting a new sending unit where the plug right above it is?
 

·
Registered
Joined
·
2,963 Posts
Discussion Starter #3
Nevermind. Did some searching on the Commander forums. Yes that is the oem sending unit, and yes take out the allen plug above it to install another sending unit.
 

·
Registered
Joined
·
1,072 Posts
I used a 3ft stainless line and remote mounted my sending unit. Its really tight in there and the weight of the sending unit and vibration of the motor could brake the fitting.
 

·
Registered
Joined
·
2,963 Posts
Discussion Starter #7
There's also a oil allen plug on the other side of the cylinders as well, you can use either one.
Theres definitly less crap in the way on the left side...
 

·
Registered
Joined
·
139 Posts
There's also a oil allen plug on the other side of the cylinders as well, you can use either one.
Hey guys,

Can you please tell me what type of thread it is where you tap in is it 1/8npt or metric?
I would to have all the fittings before I start the installation.

Thanks
Joey.S
 
1 - 9 of 9 Posts
Top