Can-Am Maverick Forum banner

1 - 19 of 19 Posts

·
Registered
2020 Maverick X3 Max X RS Turbo RR
Joined
·
320 Posts
Discussion Starter · #1 ·
I noticed a fluid leak just above the Rotax case (see photo below). It’s seems like a pretty minor leak but enough that I probably need to get it checked out at the dealer. My X3 MAX XRS RR has about 1200-1300 miles on it now and about 75 hours. The second picture shows it’s definitely oil. When I checked the oil prior to ride today it was sitting in between min and max on the stick so I added about ¼ quart. Please let me know if others have had oil leak at this location and how it turned out. I have a little over 3 months left on factory warranty and assume it would be covered. Thanks
 

·
Registered
2020 Maverick X3 Max X RS Turbo RR
Joined
·
320 Posts
Discussion Starter · #2 ·
I noticed a fluid leak just above the Rotax case (see photo below). It’s seems like a pretty minor leak but enough that I probably need to get it checked out at the dealer. My X3 MAX XRS RR has about 1200-1300 miles on it now and about 75 hours. The second picture shows it’s definitely oil. When I checked the oil prior to ride today it was sitting in between min and max on the stick so I added about ¼ quart. Please let me know if others have had oil leak at this location and how it turned out. I have a little over 3 months left on factory warranty and assume it would be covered. Thanks
258499
 

·
Registered
2020 Maverick X3 Max X RS Turbo RR
Joined
·
320 Posts
Discussion Starter · #4 ·
I noticed a fluid leak just above the Rotax case (see photo below). It’s seems like a pretty minor leak but enough that I probably need to get it checked out at the dealer. My X3 MAX XRS RR has about 1200-1300 miles on it now and about 75 hours. The second picture shows it’s definitely oil. When I checked the oil prior to ride today it was sitting in between min and max on the stick so I added about ¼ quart. Please let me know if others have had oil leak at this location and how it turned out. I have a little over 3 months left on factory warranty and assume it would be covered. Thanks
For some reason my pics weren’t posting but looks like it’s working now. In this picture you can see oil residue where I circled. The arrow points to a fresh oil drip.
258517
 

·
Registered
2020 Maverick X3 Max X RS Turbo RR
Joined
·
320 Posts
Discussion Starter · #5 ·
sure looks like the place where the coolant impeller seal weep hole is. I doubt its oil.
That was my initial thought as well but there is definitely oil there. I tried to show it in the picture, on my finger, but it’s difficult to see in the photo.
 

·
Registered
2020 Maverick X3 Max X RS Turbo RR
Joined
·
320 Posts
Discussion Starter · #8 ·
I ass ummed the coolant was green, didn’t consider it might be orange. I’ll dig into it and report back.
 

·
Registered
Joined
·
3 Posts
I just realized I never reported back on this. Turns out it was a coolant leak that I was able to resolve by tightening the hose screw clamp. Thanks for your help Mega!
I literally have the same problem, same spot. So do I just tighten what screws and how many? Please help! Jut bought with 300 miles and I’m hoping it’s just that.
 

·
Registered
2020 XDS RR, 2019 Sport 1000R
Joined
·
1,120 Posts
I just realized I never reported back on this. Turns out it was a coolant leak that I was able to resolve by tightening the hose screw clamp. Thanks for your help Mega!
Its possible, but I highly doubt tightening that clamp did a thing. More likely it just coincidentally stopped leaking on its own belive it or not.

There are 2 seals on that shaft with a gap in between to separate the oil system from the cooling system. And it is a pretty big job to change them. A good few hours of work there.

The seal will let the odd drip of coolant pass by occasionally, and it will drip out of the weep hole. Usually from temperature changes. Sort of the same way an old school small block Chevy will dump a little bit of coolant onto the intake from the thermostat housing in freezing weather.
 

·
Registered
2020 XDS RR, 2019 Sport 1000R
Joined
·
1,120 Posts
I literally have the same problem, same spot. So do I just tighten what screws and how many? Please help! Jut bought with 300 miles and I’m hoping it’s just that.
Some of these machines tend to drip the odd drop of coolant out of the weep hole when new like I mentioned above.

Mine did the same a couple times in the first few hundred miles. But not even remotely close to bad enough to noticable in the coolant level. Like maybe a tea spoon in total over weeks.

Mine stopped dripping last summer and never has since.

My suggestion is do not worry or stress about it and see what happens over the next few months. I suspect it will stop on its own.
 

·
Registered
Joined
·
3 Posts
Some of these machines tend to drip the odd drop of coolant out of the weep hole when new like I mentioned above.

Mine did the same a couple times in the first few hundred miles. But not even remotely close to bad enough to noticable in the coolant level. Like maybe a tea spoon in total over weeks.

Mine stopped dripping last summer and never has since.

My suggestion is do not worry or stress about it and see what happens over the next few months. I suspect it will stop on its own.
Right on man! Thank you for the information! When I was reading the comments, I was like yes it was oily water! Glad I found this and hopefully it stops when I put more miles on it! Again thank you and thank you for replying back!
 

·
Registered
2020 XDS RR, 2019 Sport 1000R
Joined
·
1,120 Posts
Right on man! Thank you for the information! When I was reading the comments, I was like yes it was oily water! Glad I found this and hopefully it stops when I put more miles on it! Again thank you and thank you for replying back!
Just be sure to keep an eye on it, and keep an eye on your coolant level. Better safe than sorry. Nothing is for sure. But I think your situation is not likely a huge deal. And not worth the pain in the ass to take action on at this time.
 

·
Registered
2020 XDS RR, 2019 Sport 1000R
Joined
·
1,120 Posts
Had this issue. Tightened the hose clamp and it never appeared again.
Not impossible it was the hose clamp. But highly doubtful it was the hose clamp.

Almost for sure coming from the weep hole on the bottom of the water pump body. Its just so infrequent and random that tightening the clamp made you think you fixed it by coincidence.
 

·
Registered
2020 XDS RR, 2019 Sport 1000R
Joined
·
1,120 Posts
Thank you brotha! This makes me feel better ! Appreciate it
You can still tighten that hose clamp like these guys suggest. It is possible thats whats up. Just not very likely. Like 99% weep hole. 1% hose clamp.

Look for that little hole on the bottom of the pump where the shaft would go through. You will see it..
 

·
Registered
Joined
·
96 Posts
Thank you brotha! This makes me feel better ! Appreciate it
Just check all the clamps back there and make sure they are tight. I made a post about my leak a few months ago and everyone told me to check my clamps. Hopefully yours is the same easy issue.
 
1 - 19 of 19 Posts
Top