Can-Am Maverick Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
I noticed that there is evidence of liquid possibly spraying and pooling onthe inside of the skid plate under the engine. Not sure what this would be or if this is normal. I wiped it with a paper towel but it’s dusty down there so that might have something to do with the color. Some of the hose covers are showing wet too

Only has 25 miles on it and 1 trail ride.
263858
263859
263860
263861
 

·
Registered
Joined
·
45 Posts
Discussion Starter #2
Checked oil level. It’s good. This wet area does not smell like engine oil. Just checked.
 

·
Registered
Joined
·
140 Posts
That clamp with the blue bracket took a 1/4 turn on mine this weekend. Just snugged it up and stopped a small seepage. That coolant seems kind of like oil but really thin. also slight snug up on the water pump cover bolts 8mm socket.
 

·
Registered
2020 Maverick X3 Max X RS Turbo RR
Joined
·
288 Posts
That clamp with the blue bracket took a 1/4 turn on mine this weekend. Just snugged it up and stopped a small seepage. That coolant seems kind of like oil but really thin. also slight snug up on the water pump cover bolts 8mm socket.
I had exact same issue, believe it was the clamp with the blue bracket in your picture. Once I snugged it up it hasn’t leaked since in ~2k miles.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #6
I had exact same issue, believe it was the clamp with the blue bracket in your picture. Once I snugged it up it hasn’t leaked since in ~2k miles.
Tightned this one and took it for a spin. I don’t see any new liquid. Will monitor how it goes on the next trail ride.
 

·
Registered
Joined
·
1 Posts
Anyone think this is possible the same issue? Or something different? The last 2 photos are after I’ve left the Can Am idling for about 10 mins
264576
264577
264578
 
1 - 7 of 7 Posts
Top