Can-Am Maverick Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter #1
Picked up my new xmr last week and with all this florida rain it's been a little wet to say the least. While washing it I removed the seats and to my surprise the oil dipstick was just sitting in the tube not screwed in at all. Keep in mind it now has 7.3 hrs on it and I've only had it out 2 days and never checked the oil myself only the dealership has touched it. now I have to deal with them in the morning and hope no foreign debris has entered the engine.
 

·
Registered
Joined
·
2,964 Posts
This is exactly why the 1st thing I do to a new ride is start tearing it apart as soon as I get it home. My wife thinks I'm nuts, but I have found much worse things than a dip stick not screwed in.
 

·
Registered
Joined
·
367 Posts
God I hate dealership mechanics.
Did you take a pic or video?

I would do at least 2 oil changes just for the piece of mind.
I would also call BRP and get it documented.
 

·
Registered
Joined
·
367 Posts
I agree 100% with Andy
Get the plastics off and start checking stuff
You'll be amazed
I've found loose bolts,spare clamps
I ve had a carburetor blow off
A wheel come off
A dipstick not even installed left laying on the motor!
You name it
 

·
Registered
Joined
·
1,205 Posts
I'm just glad I got to un-crate and assemble my Max myself! No one is gonna care as much about the details as the owner will. For the knot-head "mechanics" at the dealer, too many times assembly is just another unpleasant & monotonous task to perform to get the that paycheck. Truth is, all of us should really want to know as much about our machines as possible, and that ain't gonna happen unless you're willing to dive in and learn. To me, that just enhances the ownership experience.
 

·
Registered
Joined
·
7,381 Posts
I agree 100% with Andy
Get the plastics off and start checking stuff
You'll be amazed
I've found loose bolts,spare clamps
I ve had a carburetor blow off
A wheel come off
A dipstick not even installed left laying on the motor!
You name it
Same here...I have trust issues when it comes to my equipment....any usually for a good reason.
 

·
Registered
Joined
·
1,103 Posts
Same here...I have trust issues when it comes to my equipment....any usually for a good reason.
Amen brother...

Sent from my SCH-I545 using Tapatalk
 

·
Registered
Joined
·
272 Posts
I'm just glad I got to un-crate and assemble my Max myself! No one is gonna care as much about the details as the owner will. For the knot-head "mechanics" at the dealer, too many times assembly is just another unpleasant & monotonous task to perform to get the that paycheck. Truth is, all of us should really want to know as much about our machines as possible, and that ain't gonna happen unless you're willing to dive in and learn. To me, that just enhances the ownership experience.
X2, I get a lot of enjoyment out of working on mine. It's a great stress reliever to me.

Nathan
 

·
Registered
Joined
·
7,381 Posts
check your lug nuts to and your bead screws, bet there not correct either. grease all zerks to
don't forget to pull the shocks and grease those dry bushings before the eat themselves up...
 

·
Registered
Joined
·
93 Posts
Discussion Starter #12
Thanks for all the helpful info. Haven't gotten around to it but this Saturday I'm going to do the shock bushings etc. taking it to the dealership the following Monday for the loose dipstick issue they're cooperating pretty well and plan to be there with the mechanic who drains the oil and I'm going to take 2 vials for oil analyses for my own records. And to send results to BRP. I Don't plan on riding it till I have these issues taken care of.
 

·
Registered
Joined
·
229 Posts
When I bought my Commander 1000 the same thing happened to me. My first ride out I smelled oil and than shut it down for a look-around. Found my dip stick was laying on my skid plate and oil puked out everywhere. Lesson learned... check everything after a dealer touches anything!!
 

·
Registered
Joined
·
382 Posts
I had an oil leak after my first ride. The dipstick tube was lose. Tightened up and good to go. Hasn't come lose since so dealer must not have Tightened it.
 

·
Registered
Joined
·
413 Posts
Real first shake down run this weekend I notice a loud metallic banging type noise thought I broke a shock could not find the source of noise, during clean up for the top roll bar bolts loose ready to fall out....


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
367 Posts

found this little gem making a godawful rattling noise as I rode
it was wedged between the skid plate and the bottom of the motor.
that wasn't the only problem...
upon the delivery of my machine the rubber pipe bracket wasn't connected so the 2 pipes were banging into each other as I rode.
aint it great!
 

·
Registered
Joined
·
7,381 Posts

found this little gem making a godawful rattling noise as I rode
it was wedged between the skid plate and the bottom of the motor.
that wasn't the only problem...
upon the delivery of my machine the rubber pipe bracket wasn't connected so the 2 pipes were banging into each other as I rode.
aint it great!
Sounds like you had a shitty dealer because they obviously did not do any of the vehicle assembly checks....
 

·
Registered
Joined
·
1,205 Posts
.....And they wonder why we don't trust 'em! Jeez!
 

·
Registered
Joined
·
413 Posts
I had PDI issues with Bert's in Covina CA. I blasted them in a Can Am survey. Sad thing is I have a dealer 2 miles from me, Bert's a hour away. My dealer asked where I bought it told him Bert's, he gets pissed states he would if gave me a better deal but more importantly said there PDI are not done right & it's not a warranty issue it's there issue. I fixed all that I found so far but far from happy now I don't go to either dealer!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,964 Posts
Bought a used '04 Kawi ZX-10 from Bert's in 2006. I made it to the SB 605 fwy and Peck rd, when the engine oil plug fell out and dumped every ounce of oil on the rear tire. I did a slide from the car pool lane, across 4 lanes of heavy traffic to the shoulder at about 70 mph. How I kept it on 2 wheels I have no idea. I called bert's to send a truck to pick up me and the bike. When we got back to the dealership I rip the service manager a new ass. The sales manager told me he would give me $100 in store credit. I told him to stick his store credit up his ass, and that they were going to give me a new bike. The sales manager said he couldn't do it, so I made such a stink, every customer in the store (it's a big ass store) knew what happened.The sales manager finally called the owner since I wouldn't calm down. The owner told him to undo the deal, and give me a brand new ZX-10 for the price I paid for the used one. I left with my NEW '06 ZX-10 and never returned. I wouldn't set foot in that store if my life depended on it.
 
1 - 20 of 21 Posts
Top