Can-Am Maverick Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
My 2013 maverick Xrs will only pull about 7600 rpms under full throttle from a stop to full speed. When it was brand new it would pull around 7900-7950 which was a big difference in power! Right from when it was brand new I ran it wide open lots as and on and off the throttle lots as I was more worried about breaking in the motor then breaking in the belt. :big smile: I was running in lots of snow so it is hard going. I also have a bit of a howl noise that just developed coming from my belt when just barely moving. Could it be a belt issue already?I only have about 100 miles on it now sorry for all the questions as this is my first side by side so it's all new to me.
 

·
Registered
Joined
·
158 Posts
Mine hits the 7950/8050 rpms at full throtle
Stock motor, stock belt with 2450 miles since new...
Never had an issue
I never changed a belt ...:big smile:
 

·
Registered
Joined
·
177 Posts
if not the belt , check the arms on the primary, i had one sticking with only a few hundred miles on it. It would not rev right
 

·
Registered
Joined
·
99 Posts
Mines doing the same thing. Only hitting 7500~7600 rpms now that i have about 800 miles on it. Ill have to check the arms on the primary. If that doesnt do it i was thinking i would give a dalton clutch kit a try.
 

·
Registered
Joined
·
177 Posts
I installed the dalton kit , thats how i found the sticking arm.
 

·
Registered
Joined
·
216 Posts
Mine was same way worked good right away and like you ran it hard right away never let belt break in, now mine hits 7600 when I punch it the shifts through in mid range all the way down to 7100 then slowly crawls up to 8000... I am wondering if we didn't break in the belt right or something... going in this week to get the 10 hour service and full STM setup and will be putting on new belt at same time
 

·
Registered
Joined
·
177 Posts
Don't have alot of miles on it. Im waiting on a controler . But so far so good.and yes stock tires
 

·
Registered
Joined
·
461 Posts
I bet you guys have weak secondary springs. Try to get the dealer to replace the secondary spring. I went through 2 of them and then Bought the dalton black/violet spring. Problem solved. I upgraded to qsc/STM after that. I still have the dalton spring if anyone wants it. Pm me.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,963 Posts
I bet you guys have weak secondary springs. Try to get the dealer to replace the secondary spring. I went through 2 of them and then Bought the dalton black/violet spring. Problem solved. I upgraded to qsc/STM after that. I still have the dalton spring if anyone wants it. Pm me.


Sent from my iPhone using Tapatalk
^^^^^^^^^^^^^^what he said. The black/violet Dalton secondary spring fixed mine as well when I was using the stock secondary clutch.
 

·
Registered
Joined
·
99 Posts
^^^^^^^^^^^^^^what he said. The black/violet Dalton secondary spring fixed mine as well when I was using the stock secondary clutch.
Good to know, thanks. Just talked to my dealer, im off warranty now but they do have some Dalton springs in stock. Ill have to pick one up.
 

·
Registered
Joined
·
2,963 Posts
Yeah, it seems the stock secondary spring is a hit or mis deal. Been several of us that the spring just didn't retain it's tension, but many have had no issue with it. Go figure......
 

·
Registered
Joined
·
461 Posts
If anyone wants mine I'll let it go for $40 plus shipping. I think they are $55-$60 plus shipping new. This one has about 75-100 miles on it. Pm me.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
546 Posts
I have a 14 max. I haven't ran mine past60 mph yet. Guess I should test the waters and see how high mine goes..
 

·
Registered
Joined
·
548 Posts
Mine has been hitting 7950 in low range (with sport mode), but only gets to about 7600-7700 in high range. I think I'm going to look into the dalton kit for mine. I thought it was a bit odd that it would get up there in low but not in high.
 

·
Registered
Joined
·
99 Posts
Mine has been hitting 7950 in low range (with sport mode), but only gets to about 7600-7700 in high range. I think I'm going to look into the dalton kit for mine. I thought it was a bit odd that it would get up there in low but not in high.
Mine will hit 8150 in sport low. In hi range when i punch it the rpms go to 7450-7600 until i get up to hi 60 mph's, then she starts revving out. Its got about 50 hours on it, 1100 kms.
 
1 - 20 of 28 Posts
Top