Can-Am Maverick Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
So I just brought my brand new maverick home from the dealer and I can only get the thing to go 15mph. At first I thought it was already in limp mode, however, I noticed when I first power it on I get a “reprogram key” warning. Is this what could be causing it to limit the speed to 15mph? I’ve searched everywhere in the manual to try diagnosing the problem but can’t figure it out.

I’ve only owned the thing for an hour. Looks like a trip back to the stealership is in order.

Thanks in advance for any help you may provide.
 

·
Registered
Joined
·
621 Posts
So I just brought my brand new maverick home from the dealer and I can only get the thing to go 15mph. At first I thought it was already in limp mode, however, I noticed when I first power it on I get a “reprogram key” warning. Is this what could be causing it to limit the speed to 15mph? I’ve searched everywhere in the manual to try diagnosing the problem but can’t figure it out.

I’ve only owned the thing for an hour. Looks like a trip back to the stealership is in order.

Thanks in advance for any help you may provide.
Did you have the seatbelt on?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
they didn't prog the key at dealer. x3 come from factory with key programmed to only go 15 during transport. part of pdi procedure by dealer to program key to normal or performance.
Alright that’s kind of what I thought. Thank you for the confirmation. Hopefully I can get it in Friday. I would assume they need the whole machine and not just the key, correct?
 

·
Registered
2021 xds turbo rr
Joined
·
25 Posts
Call the dealership and raise hell. If they didn't do that basic step then they might have missed other basic steps as well. Get some compensation from them for this appalling major **** up. You spent large on a new machine so it's time they pay the piper.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
Call the dealership and raise hell. If they didn't do that basic step then they might have missed other basic steps as well. Get some compensation from them for this appalling major **** up. You spent large on a new machine so it's time they pay the piper.
I’m starting to think I got hosed by the dealer. Shortly after unloading it from there trailer, I found a random washer sitting under where it was parked for 10 minutes.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #11 · (Edited)
I’m not telling you all the whole story. So, I get this thing home and off the trailer. I then go inside to file some paperwork and when I come back out is when I found the random washer. I then fire it up and notice “maintenance required” on the dash. I think that’s fricken weird, restart it and still the wrench doesn’t go away.

At this point I’m thinking, does this thing even drive? I buckle my seat belt, put it in H and go to drive down my gravel road and it only goes 15mph. I noticed on the dash the ”buckle” alarm didn’t go off even though I had. I look under the seat and low and behold a blue wire was disconnected. I restarted it and that was when the dash displayed reprogram key.

I’m like 99% sure this dealership bent me over and sold me a lemon/something rush assembled. They did say that it was a canceled order and that was why it was on the show floor. I’m actually pretty livid and don’t even know if I want this thing now.

Also @LBR , Thank you for the welcomes. Just looking for guidance on what I should do at this point.
 

·
Registered
Joined
·
328 Posts
Going back calm might get you further, especially if that is your local dealer. They screwed up but you need to develop a good relationship with them for the future. Just my opinion.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #14 ·
Call the dealership and raise hell. If they didn't do that basic step then they might have missed other basic steps as well. Get some compensation from them for this appalling major **** up. You spent large on a new machine so it's time they pay the piper.
Alright, I sent an email to the sales guy complete with photos and will be calling them the moment they open on Friday. I’m kind of mad that during my excitement I cleared the “maintenance required” notification I completely agree that this is a major **** up on their part. I have an unusable $30,000 machine sitting in my garage.
 

·
Premium Member
Joined
·
14,238 Posts
Welcome from Tucson AZ. Trying to play the devil's advocate here, did you do a walk around the car with the dealer? You're supposed to. They did miss the key program, that's happened to a lot of members. So has the "extra parts" scattered throughout the car on the floorboards, and skidplates. Shit happens.

Go back with your car and let them reprogram your key. You didn't get screwed over, and it's not the end of the world. Yes, the dealer could have been a lot better. I'd check the glove box to make sure you have a clutch spreader tool. If not, get one of those when you go back to the dealership.
 

·
Registered
Joined
·
4,367 Posts
Welcome from NW Oregon

Yes, you are far from being the only one who had issues upon delivery or with a new machine. I had a new $45,000 unusable (upgraded) machine in the dealers shop for over 2 months torn all apart and throwing over $4500 worth of parts and labor that didn't fix the problem. Had to pull it and take it to a different dealer who was competent during the middle of the riding season where I had to cancel several trips with family.
It's very frustrating, but it will get figured out!
 

·
Premium Member
Joined
·
2,338 Posts
Alright, I sent an email to the sales guy complete with photos and will be calling them the moment they open on Friday. I’m kind of mad that during my excitement I cleared the “maintenance required” notification I completely agree that this is a major **** up on their part. I have an unusable $30,000 machine sitting in my garage.
Calm down. Lol like others said it’s not the end of the world. Shit happens and it will get fixed. I wouldn’t go in there all fired up and show your ass. At the end of the day 30k$ is nothing to a dealership . People drop more than that everyday there I’m sure. It’s a key relax . Play it cool and I’d bet they take care of you in the future as well.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
41 Posts
relax - one washer the unit will be fine. it has to be assembled when they get it and the kit has extra parts. I would wager a "tech" did not pot it together. the key and maintenance light our a tech responsibility and should have been given to them. maintenance light is an issue with new x3 and there is a "flash" for the cluster that should have been done. not to slight your concerns but our sales rep is telling us that x3 will be shipped without ecu and they wont be available til late spring. you our fortunate to get a 22. did you not test drive the unit before purchase? we let them test drive and then if they purchase let them take it to gas station (with us) so we can fill it up. where our you located?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #19 ·
relax - one washer the unit will be fine. it has to be assembled when they get it and the kit has extra parts. I would wager a "tech" did not pot it together. the key and maintenance light our a tech responsibility and should have been given to them. maintenance light is an issue with new x3 and there is a "flash" for the cluster that should have been done. not to slight your concerns but our sales rep is telling us that x3 will be shipped without ecu and they wont be available til late spring. you our fortunate to get a 22. did you not test drive the unit before purchase? we let them test drive and then if they purchase let them take it to gas station (with us) so we can fill it up. where our you located?
I’ve had time to cool off, although, I still find it unacceptable that wires were disconnected, the key wasn’t programmed, maintenance required flashed across the screen, and hardware was found under it after taking it off the trailer. I get it, accidents happen and we are all human, however, compounding events and dropping $30k on a unit sort of leaves a bad taste in my mouth and I don’t think it’s unacceptable to think this way. My time also has value and this is taking up a good deal of it. Yes, I am confident they will make it right, but when I specifically ask the sales guy why on their checklist it says “program D.E.S.S“ was marked “NA” by a tech and his reply was it wasn’t needed for this model. When he called me after reading my email this morning, he also brought up that the seatbelt needs to be on for it to go over 15mph, which tells me he didn’t really even bother reading my email. He mentioned at all of their machines have been driven following assembly which sort of came off as him saying “it worked before it left here.”

I am not without fault concerning a test drive. It was never really brought up and I didn’t do my job in asking. After the walk around the dealer simply told me to put it in low range when driving onto the trailer. Which I did and noticed it only went 15mph but I thought the ecu might limit the speed to 15 in low range. Again, I’m an idiot for not asking and hopefully others can learn from my mistake. My mind was sort of “excitement drunk” as I have been saving up for one of these machines for the past 7 years.

Yes, I am fortunate to get a 22. It was sort of a right place at the right time deal. I would like to keep my location and dealer anonymous until at least this stuff gets cleared up to give them a chance at making it right (I’m sure they will).
 
1 - 19 of 19 Posts
Top