Can-Am Maverick Forum banner
81 - 100 of 136 Posts

·
Registered
Joined
·
6,621 Posts
Gotcha. I will be doing the same to mine over this coming weekend.
Nice beads!!
 

·
Registered
Joined
·
3,127 Posts
Discussion Starter · #86 ·
Too stiff through the whoops! It handled them great, along with the large stuff, but I could feel my chest and my guts getting rattled hard compared to my last ride. Also, my helmet bounced around too much. I backed off the compression and rebound to 6 clicks each, and I am going to try it out this morning and adjust from there. Also, the rebound has 24 distinct clicks. But, the compression has no clicks. There are 6 lines marked, and it uses 20 lines total. So I backed out the high and low compression, then turned them in one turn, which equals 6 clicks.
 

·
Registered
Joined
·
3,127 Posts
Discussion Starter · #87 ·
I put about 30 miles on it today. I did a few donuts, and the shaft saver didn't kick in! I drove it very hard through whoops and small jumps, and the shaft saver only kicked in once, and even then just barely! I've been all over the place with the shock settings, and I'm getting close. The manual has recommended settings, and they're pretty close. I have lowered it twice. It started with 13" ground clearance, and it now has 11. 5". At 13" gc, it has 5" of down travel, and 9" of up travel. Now it has ,6.5" down and 7.5"up. I'll be trying this setup tomorrow. :cool:
 

·
Registered
Joined
·
6,621 Posts
Yeah I also softened all my shock settings except preload. I'm all the way out so it's the softest it can be without revalving. Soaks up the whoops at 63-65mph no problem. But I'm sure I'll keep playing with it to make it a little better.
 

·
Registered
Joined
·
6,621 Posts
My rear shocks are now at 0 high and low speed compression. Still a little too stiff. The rebound is going to wind up somewhere around 10 to 15 clicks.
Hope you had fun riding with us yesterday. Those washes are so much fun. Like a one way race track. We then rode over to the back bowl and Mav torn it up with no problems.
 

·
Registered
Joined
·
3,127 Posts
Discussion Starter · #92 ·
Yup, great ride! I wish I would have fueled up before I went on that ride! I was just out messing around, and one thing led to another, and I ran into you guys.
 

·
Registered
Joined
·
6,621 Posts
Yup, great ride! I wish I would have fueled up before I went on that ride! I was just out messing around, and one thing led to another, and I ran into you guys.
You've should said something cus I could've given ya a splash at our camp. I needs some as well.
 

·
Registered
Joined
·
3,127 Posts
Discussion Starter · #94 ·
A pic of the lights I added, 2 hid's plus 1 led. The stock have been converted to hid, so that gives me 6 hid's and 1 led! Should light up the night. Also, I tried covering one of the yellow panels in vinyl, but it didn't turn out good. So I Plastidip'd it.
 

·
Registered
Joined
·
10,454 Posts
looks good! Does the LED do anything with all the HID lights on? How big is the stator?
 

·
Registered
Joined
·
3,127 Posts
Discussion Starter · #97 ·
I haven't tried them yet, still wiring them up. I have six 55 watt hid' plus the led for a total of almost 400 watts. The stator is 610 watts, or 640. All the hid' have the 3x4x1" metal ballast.
 

·
Registered
Joined
·
461 Posts
Can you put an ebay link up for the kit you bought for the stock lights? Definately going to be the first thing I do to mine when I get it.
 

·
Premium Member
Joined
·
9,060 Posts
I haven't tried them yet, still wiring them up. I have six 55 watt hid' plus the led for a total of almost 400 watts. The stator is 610 watts, or 640. All the hid' have the 3x4x1" metal ballast.
Where did you mount the ballasts? I ran 4 hella lights with 55watt hid conversions on my rzr1 and it was stupid bright, but they pulled a lot of power.
 

·
Registered
Joined
·
6,621 Posts
I believe the stator is 640 watt output.
 
81 - 100 of 136 Posts
Top