Can-Am Maverick Forum banner

1 - 20 of 39 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I was riding my maverick today and stopped for a few minutes and it would not restart. When I insert and turn the key everything powers up fine and sounds right but when I push the start button nothing! The screen says it does not recognize the dss key>>> Anyone out there have a fix for this problem???
 

·
Registered
Joined
·
2,964 Posts
Oh hell...That blows. I haven't heard of that happening before
 

·
Registered
Joined
·
4,536 Posts
did u try ur spare key ? might just be a bad key


brp has been using these same key design for over 8 years on there seadoo's ,quads and commander so its not a new thing



I was riding my maverick today and stopped for a few minutes and it would not restart. When I insert and turn the key everything powers up fine and sounds right but when I push the start button nothing! The screen says it does not recognize the dss key>>> Anyone out there have a fix for this problem???
 

·
Registered
Joined
·
1,466 Posts
I was riding my maverick today and stopped for a few minutes and it would not restart. When I insert and turn the key everything powers up fine and sounds right but when I push the start button nothing! The screen says it does not recognize the dss key>>> Anyone out there have a fix for this problem???
Take it to the dealer and they can clear that code.
 

·
Registered
Joined
·
256 Posts
Mine did that also..... till I realized I was using our commander key... lol switched back to mav key.... doh...

If Im on the side of the trail posting ... its because Im waiting for you to catch up.
 
  • Like
Reactions: MN Mav

·
Registered
Joined
·
7,381 Posts
make sure the key is clean and if it still doesn't work, try your spare key.
 

·
Registered
Joined
·
1,272 Posts
Hopefully u didn't accidentally crack the computer chip in the key, cause it will never work then..
 

·
Premium Member
Joined
·
8,276 Posts
Make sure your dash shows if you are in neutral, it could be the trans switch not letting the computer start the machine. Also make sure your brake switch works too. It has to be something electrical not letting it start. Unless you were in a freak electrical vortex that cleared your key and made you sterile.
 

·
Registered
Joined
·
791 Posts
You could try spray into your ignition with WD-40 or compressed air to see if that helps. I have had problems before when moisture got into the ignition switch. Worked for me.
 

·
Registered
Joined
·
791 Posts
Eeeeek. Just say no to whistle dick in electrical plugs.
No worries Bud. I have been driving Can-Am's under water for years. I know what works a what does not. If you put some dielectric grease in there in the first place you should never have a problem due to moisture. Not sure if the OP's problem is moisture related, but ya never know.
 

·
Premium Member
Joined
·
8,276 Posts
now its my turn. Key will not do anything. went for a ride and stopped for drinks then went to start and nothing on dash. power to fuse panel, power to ignition switch, power out of start button, fuel pump whines, i can jump starter relay but it will not fire up.

just called my dealer they said it has to be ecu then.

one half a day riding in the dunes now i am done. fawk me
 

·
Registered
Joined
·
2,964 Posts
now its my turn. Key will not do anything. went for a ride and stopped for drinks then went to start and nothing on dash. power to fuse panel, power to ignition switch, power out of start button, fuel pump whines, i can jump starter relay but it will not fire up.

just called my dealer they said it has to be ecu then.

one half a day riding in the dunes now i am done. fawk me
NOOOOOOOOOOOOO!!! I been leary of the push button ignition from day 1, but never thought the key would be a problem...That sux donkey bawls Mike. Theres nothing or nobody anywhere near mother G to get you fixed up?
 
1 - 20 of 39 Posts
Top