Can-Am Maverick Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Went riding last weekend and on the last day I was just sitting in some water with my bike just deep enough for the belt housing to be under. When I went to pull out it was slipping bad, checked the drain port and sure enough had a good bit of water in it, to my surprise the drain port was this cheap little rubber/plastic grommet with a wire type piece to hold it on. My thoughts is its that leaking by but im not sure it could be anything, my question is anyone having issues with the belt housing leaking on the back side or anything else? Im fixing to do a clutch on it so im prolly going to pull the belt housing and seal the back side possible get a new gasket for the middle section and figure out a better way of making a drain port, just wanted to see what peoples experiences have been. thanks
 

·
Premium Member
Joined
·
8,476 Posts
it has a nice gasket, check it to see if it folded over. also check the inlet boot, its kind of akward to install when you take it off and could be not seated all the way. You could check the outlet boot too.

i would not silicone the cover on, it would make replacing a belt a pita. But you could remove the clutches and silicone the plastic housing to engine/grarcase.
 

·
Registered
Joined
·
65 Posts
it leaks in from back side of clutch cover where the shafts come through. itake off both clutches and silicon back cover to motor
 

·
Registered
Joined
·
30 Posts
Discussion Starter #4
No I wasnt going to seal where the gasket is possibly just replace it if need by, I was going to silicone the back side of the housing that is on the motor. I had to do the same thing with several other of my bikes, thanks for the reply's has anyone done anything about the drain port?
 
1 - 4 of 4 Posts
Top