Can-Am Maverick Forum banner
21 - 26 of 26 Posts

·
Registered
Joined
·
410 Posts
Ight guy I bought the new fan plugged it up to make sure it's going to work and it don't so something isn't right. I'm not gettin power to the plug now and all the relays and fuses are good. Anymore ideas
Has it ever worked since you installed the fan override? Start at the switch and make sure you have 12v in, then turn it on and make sure you have 12v out, if so make sure you are energizing the relay could be relay contact failure. What's different since you said you had power at the plug b4?
 

·
Registered
Joined
·
7,381 Posts
silly question but are you getting it hot enough for the fan to come on or do you have a fan override installed? Connect it to a known good 12vdc source and see if the fan works.....then start tracing the lines back to the power source until you find the culprit. It is either not hot enough to turn it on, or there is a break in the wiring or the fuse or relay is bad.....
 

·
Registered
Joined
·
410 Posts
silly question but are you getting it hot enough for the fan to come on or do you have a fan override installed? Connect it to a known good 12vdc source and see if the fan works.....then start tracing the lines back to the power source until you find the culprit. It is either not hot enough to turn it on, or there is a break in the wiring or the fuse or relay is bad.....
He has an override.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #24 ·
Ok thanks for the help. Didn't have a plug connected all the way or something. It all works now. Thanks for the help once again
 

·
Registered
Joined
·
21 Posts
My fan also went out and a guy that works at pit proven performance told me he uses the hayden 3680 on his canams. Bought it at orielys for 60 bucks and it has a lifetime warranty. He said he has never had a problem with them tho. But if you do you can always take advantage of the warranty!
 
21 - 26 of 26 Posts
Top