Can-Am Maverick Forum banner
1 - 7 of 7 Posts

·
Vendor
Joined
·
594 Posts
thanks guys ill call the dealer today and bring it in. my gut has been saying it needs to be reprogrammed. what is difficult to understand is that there was one other person who claimed their dealership mentioned the break in chip also... BRP still has not gotten back to me so without speaking to them how can we know if this is true or not?
It is not true, get the RPM at wide open for us, could be clutch related. If hitting 8000 rpm at 60 mph then look at the clutch.
 

·
Vendor
Joined
·
594 Posts
ok give me one minute ill head out and take her up and down the road a couple times. i think the RPMs are going to be ok, when it cuts off at 60 mph it feels like its supposed to be doing it, no weird engine noise or anything like that. it truly seems like it is programmed to cut off at 60. be right back with RPM info...
Was fixing to head out to go do some bush hogging at deer camp but had this thought, if there was such a thing as a break in limiter, why aren't they all doing this and it would be common knowledge. So your dealer would want you to think BRP selects only one in 10,000 to program for a break in and that one is yours?????
 

·
Vendor
Joined
·
594 Posts
ok so RPMs were at 8 when it cut off. BUT today it went over 60mph before it cut out, ended up going near 66mph before cutting out. when it cuts off the transmission light comes on for a split second. any ideas?
I am not sure what a transmission light means on this unit, need to dig into it but probably it means the computer says the belt is slipping. Either way the fact you are turning the right RPM but wrong speed means something is wrong in your clutch, what??? I have no idea could be a bunch of different things but it is something wrong in there.
 

·
Vendor
Joined
·
594 Posts
Laste reply, I gotta get outta here!!

I am used to UTV's that are not this smart, so since you have this error on dash then something is wrong somewhere is making it go in say limp mode. The issue is either the clutching, some sensor somewhere etc. No matter what it needs to go back to dealer but does not sound like yours is very sharp.
 

·
Vendor
Joined
·
594 Posts
The only way it is not the clutch is a speed limiter. Take a Kawasaki Teryx, it has a 50 mph limiter, you can do change the RPM in clutching etc but it will not go over 50 even if you raise or lower RPM in clutch.

So it is either the clutch as mentioned or some electrical crap with that light you have putting a speed limiter but not RPM limiter in place.

Todd
 

·
Vendor
Joined
·
594 Posts
No other dealers near by... this sucks so bad. Im taking it back today. anybody have a reputable dealer number that i could call today just to chat with? location does not matter as i will not be bring my bike into them, just want to speak with someone who knows a lot about the mavericks? anyone?
What dealer is open on a sunday?

How about just riding for 10 hours and prove them wrong?

How about all these guys on here trying to tell you something is wrong?

Bottom line, no break in chip or whatever, something is wrong with your maverick.

Todd
 
1 - 7 of 7 Posts
Top