Can-Am Maverick Forum banner

1 - 20 of 60 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hey everyone, i recently bought a 2013 Maverick X rs, recently as in it only has 5 hours on it. after a couple hours of cruising around i decided to put a little more foot to the gas and noticed that the engine cuts off at 60 MPH?... it does not die, but it limits me from going any faster.. please help me. here are some details...

I am using the performance key, it even says so on the screen when i turn the bike on.
It is in sport mode, even though that should not make a difference.
Everything on the bike is fully stock.

As soon as i first experienced this problem i called my dealer and spoke with my sales rep. This person is a great guy and really did a lot for me during the purchase of the bike. he is not fluent in mavericks and relies on his tech crew for information about this type of thing. when he spoke with his crew, one person told him that the Maverick has an engine break in chip that protects it from going over 60mph for the first ten hours, and then after that it unlocks it 100%...

Is this true? i cannot find ANYTHING about this in the manuals or online anywhere! ive been searching for days and nothing. i called BRP but their service was having high call volume issues so i emailed them and am yet to hear back.

PLEASE someone help me! The person i bought it from is only relaying this information from his team and is very honest about that fact, together we have been trying to figure it out. He seems to be convinced that the chip exists but i have to be honest... i am having a very hard time believing it. i have owned 1000cc Can am outlanders and Renegades and never heard of anything like this. AND i would think that at least ONE person who bought a maverick would be asking this same question but i cant find anything!

Sorry for the long post, thank you in advance for your advice..
 

·
Registered
Joined
·
4,536 Posts
your dealer is a dumbshit if they say 60 is ok, LOL
 
  • Like
Reactions: Hunterworks

·
Registered
Joined
·
13 Posts
Discussion Starter #5
not sure of the RPMs, ill be taking it out first thing in the morning and ill report back.

Nobody has ever heard of an engine break in type of computer chip that limits the engine during break in??
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
it drives very strong up to 60mph and then just cuts out, if i accelerate back up to 60 it will just cut back out again and again. no other issues at all.
 

·
Registered
Joined
·
1,777 Posts
My dealer told me also about a break in chip. I tried a demo Mav and they told me it would not run real fast yet because of the chip. They were afraid I might be disappointed because I also test drove a Polaris XP. Polaris was still slower than the Mav that I demoed.
 

·
Registered
Joined
·
2,964 Posts
not sure of the RPMs, ill be taking it out first thing in the morning and ill report back.

Nobody has ever heard of an engine break in type of computer chip that limits the engine during break in??
Who ever told you that is full of shit. No break in chip in the ECU. Within the 1st 15 miles on the odometer, I had already hit 77 mph twice
 

·
Registered
Joined
·
424 Posts
We pulled 79 mph with .03 hours on the clock. There is no "break in chip" or anything like that. Sounds like the "performance key" got programmed as a "normal key" I would verify this with your dealer. But from the sounds of it they don't know anything either.

Pro Tip: Find a new dealer
 

·
Registered
Joined
·
424 Posts
Could also be an extremely fatigued secondary spring. They've been having many issues with them on stock machines
 

·
Hickory, NC
Joined
·
2,958 Posts
Have your dealer reinstall the program, mine had a similar issue around 55mph and .6hrs. All good now after reboot
It'll almost pull wheelies now!
 

·
Registered
Joined
·
13 Posts
Discussion Starter #13
thanks guys ill call the dealer today and bring it in. my gut has been saying it needs to be reprogrammed. what is difficult to understand is that there was one other person who claimed their dealership mentioned the break in chip also... BRP still has not gotten back to me so without speaking to them how can we know if this is true or not?
 

·
Vendor
Joined
·
594 Posts
thanks guys ill call the dealer today and bring it in. my gut has been saying it needs to be reprogrammed. what is difficult to understand is that there was one other person who claimed their dealership mentioned the break in chip also... BRP still has not gotten back to me so without speaking to them how can we know if this is true or not?
It is not true, get the RPM at wide open for us, could be clutch related. If hitting 8000 rpm at 60 mph then look at the clutch.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #15
ok give me one minute ill head out and take her up and down the road a couple times. i think the RPMs are going to be ok, when it cuts off at 60 mph it feels like its supposed to be doing it, no weird engine noise or anything like that. it truly seems like it is programmed to cut off at 60. be right back with RPM info...
 

·
Registered
Joined
·
13 Posts
Discussion Starter #16
ok so RPMs were at 8 when it cut off. BUT today it went over 60mph before it cut out, ended up going near 66mph before cutting out. when it cuts off the transmission light comes on for a split second. any ideas?
 

·
Vendor
Joined
·
594 Posts
ok give me one minute ill head out and take her up and down the road a couple times. i think the RPMs are going to be ok, when it cuts off at 60 mph it feels like its supposed to be doing it, no weird engine noise or anything like that. it truly seems like it is programmed to cut off at 60. be right back with RPM info...
Was fixing to head out to go do some bush hogging at deer camp but had this thought, if there was such a thing as a break in limiter, why aren't they all doing this and it would be common knowledge. So your dealer would want you to think BRP selects only one in 10,000 to program for a break in and that one is yours?????
 

·
Registered
Joined
·
13 Posts
Discussion Starter #18
Was fixing to head out to go do some bush hogging at deer camp but had this thought, if there was such a thing as a break in limiter, why aren't they all doing this and it would be common knowledge. So your dealer would want you to think BRP selects only one in 10,000 to program for a break in and that one is yours?????

this is exactly why i have been trying so hard to figure it out, somthing is not right here. im not stupid.
 

·
Vendor
Joined
·
594 Posts
ok so RPMs were at 8 when it cut off. BUT today it went over 60mph before it cut out, ended up going near 66mph before cutting out. when it cuts off the transmission light comes on for a split second. any ideas?
I am not sure what a transmission light means on this unit, need to dig into it but probably it means the computer says the belt is slipping. Either way the fact you are turning the right RPM but wrong speed means something is wrong in your clutch, what??? I have no idea could be a bunch of different things but it is something wrong in there.
 

·
Vendor
Joined
·
594 Posts
Laste reply, I gotta get outta here!!

I am used to UTV's that are not this smart, so since you have this error on dash then something is wrong somewhere is making it go in say limp mode. The issue is either the clutching, some sensor somewhere etc. No matter what it needs to go back to dealer but does not sound like yours is very sharp.
 
1 - 20 of 60 Posts
Top