Can-Am Maverick Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
2020 x3 xds turbo rr when locked in 4wd and hit the throttle hard sounds like the prop shaft is comin through the floorboards ( shaft is tight) now if I’m going up a hill on hard surface 2wd making same noise hard throttle. If I’m easy on throttle no noise
 

·
Premium Member
Joined
·
11,032 Posts
Welcome from Tucson AZ. Possibly your sway bar clunking? Everything else tight?
 
  • Like
Reactions: Waveslayer

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Welcome from Tucson AZ. Possibly your sway bar clunking? Everything else tight?
Not the sway bar just disconnected it this last ride.maybe I should have elaborated more, I hit a hole with the left front wheel and gaged on it that’s when I started hearing the noise. But it feels like a carrier bearing bad and beating the floorboards real fast
 

·
Premium Member
Joined
·
2,153 Posts
So you hit something. That’s the kind of info we need. How big of a hole? Start by checking a arms are still tight. Ball joints and tie rod ends. Depending on how hard you hit check mounting points for a arm on left side. I’m not saying it not carrier bearing but very unlikely. We have guys with over 10k miles all on original bearings. Check your front diff bolts. You might have bent something and got it in a bind. Also stock a arms?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
So you hit something. That’s the kind of info we need. How big of a hole? Start by checking a arms are still tight. Ball joints and tie rod ends. Depending on how hard you hit check mounting points for a arm on left side. I’m not saying it not carrier bearing but very unlikely. We have guys with over 10k miles all on original bearings. Check your front diff bolts. You might have bent something and got it in a bind. Also stock a arms?


Sent from my iPhone using Tapatalk
[/QUOT
So you hit something. That’s the kind of info we need. How big of a hole? Start by checking a arms are still tight. Ball joints and tie rod ends. Depending on how hard you hit check mounting points for a arm on left side. I’m not saying it not carrier bearing but very unlikely. We have guys with over 10k miles all on original bearings. Check your front diff bolts. You might have bent something and got it in a bind. Also stock a arms?


Sent from my iPhone using Tapatalk
everything is factory. Front diff is tight. Just put two new axle shafts in . Didn’t notice anything loose. But on this last ride steer wheel was off center, center bearing is tight, I’ll be tearing it down this weekend and look at it again
 

·
Premium Member
Joined
·
2,153 Posts
Why new axle shafts? Oem? How hard did you hit? A arms a very weak. You need either taco kit which is weld in or buy some aftermarket lowers. Aftermarket axles other than rcv are usually not as good as the oem. I know that sounds crazy but it’s the truth. People think rhinos are awesome but they don’t work well with the x3. Do a little research on here and you’ll find a guy with over 30k mile on oem axles. Desert dog is his name .


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
2,153 Posts
Bad. Make sure the axle isn’t bent if it was in when you hit the hole. It could be hard to see but even the slightest bend in the axle could be your issue.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
Bad. Make sure the axle isn’t bent if it was in when you hit the hole. It could be hard to see but even the slightest bend in the axle could be your issue.


Sent from my iPhone using Tapatalk
Put axles in after making the noise
 

·
Premium Member
Joined
·
11,032 Posts
Not the sway bar just disconnected it this last ride.maybe I should have elaborated more, I hit a hole with the left front wheel and gaged on it that’s when I started hearing the noise. But it feels like a carrier bearing bad and beating the floorboards real fast
If you hit it with your left wheel, and it's stock, good chance you bent your lower left a arm. Put a straight edge on it to make sure, and like Dizzledog said, check all bolts again. Doesn't matter if it's factory, it's been proven many times the factory is less than perfect when building these. Good luck, report back.
 
  • Like
Reactions: Joejoe12

·
Registered
Joined
·
7 Posts
My 2020 xmr sport did made very similar noises, thought it was the u-joint for the front diff. Replaced it and still had the same issue. Drained the front diff and it had lots of filings and small chunks. Took it in for warranty on the diff.

This was all after being berried and breaking the drivers side axle. When it broke I assumed that’s all that was hurt. Replaced the axle and then started hearing the same noise you are describing.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #16
My 2020 xmr sport did made very similar noises, thought it was the u-joint for the front diff. Replaced it and still had the same issue. Drained the front diff and it had lots of filings and small chunks. Took it in for warranty on the diff.

This was all after being berried and breaking the drivers side axle. When it broke I assumed that’s all that was hurt. Replaced the axle and then started hearing the same noise you are describing.
I just did a full service to it. Front diff fluid was dark but not burnt normal with shaving.
 
1 - 16 of 16 Posts
Top