Can-Am Maverick Forum banner
41 - 60 of 459 Posts

·
Registered
Joined
·
707 Posts
hey guys I was wondering out of all of you having these issues did anyone use the grey key until 10 hours like my dealer has told me to do. Or did you guys just start hammering down after 5 minutes? Im still working on my 10 hours and using the grey key that feels like it has 20hp.
Drive it like I stole it!
 

·
Registered
Joined
·
221 Posts
I hit 8k all the time and mines all stock .
 

·
Registered
Joined
·
461 Posts
I'm with you guys. Mine will rarely make it over 7850 and when I hit 50 it drops to 7250. Acceleration is super slow after 50. Its at the dealership now getting this looked at so I will let u guys know what comes of it.
 
  • Like
Reactions: C.Moore

·
Registered
Joined
·
998 Posts
Yes please let us know what your dealership says, my dealership said they was nothing wrong with mine but after reading this thread and seeing such a wide variety of rpms when the clutch shifts out makes me think they are some bad springs out there
 

·
Registered
Joined
·
81 Posts
Yes please let us know what your dealership says, my dealership said they was nothing wrong with mine but after reading this thread and seeing such a wide variety of rpms when the clutch shifts out makes me think they are some bad springs out there
Hopefully it does get ironed out for the guys that this is happening to. We purchased a 101 HP machine with our hard earned money.... it should perform like one!
 

·
Registered
Joined
·
998 Posts
I have a aftermarket spring for my secondary I'll be installing this weekend, my clutching is spot on till its starts shifting out at around 45-55 mph and you can hear my engine really drag down and labor from it. I'm interested to see how the dealer handles the situation or even better see what can am says is normal
 

·
Registered
Joined
·
81 Posts
It should be interesting to see what develops from this latest "clutch saga". Hopefully Can-Am is hard at work to come up with a solid solution and not at an excuse.
 

·
Registered
Joined
·
791 Posts
I wonder if the quality of the gas some are running contributes to the inconsistency in WOT RPM's. I think the Maverick automatically backs off the timing if the fuel is not up to par.
 

·
Registered
Joined
·
791 Posts
I am going to start blending my own 91 octane using regular 87 pump gas and mixing it with Toluene.

91 octane sells for $5.30 a gallon at the pump up here and you never know what you are getting (quality and age wise) as hardly anyone buys it.
 

·
Registered
Joined
·
998 Posts
I'll have it installed this weekend for sure, I'm hoping it fixes the problem too. I feel pretty confident this is the fix for us with factory primarys so we'll see
 
41 - 60 of 459 Posts
Top