Can-Am Maverick Forum banner

21 - 40 of 66 Posts

·
Registered
Joined
·
14 Posts
23 miles/4.4hrs on mine. Had it for 2 weeks and taken it on one ride.

Sitting at the dealership now. It came from the factory with an extra valve retainer on one of the valves, causing extra stress on the valve. Well the valve broke and the piston hit it. You can guess how that ended.
 

·
Registered
Joined
·
367 Posts
900 miles on my Mad Wagon! Broke her in deer hunting in Northern Nevada back in October. Then she spent some time tearing up Dumont Dunes. Now she's a blazing the trails around Duck Creek Village, Utah. Most of the time cruising when the wife is aboard, then drive her like stole her all other times.

Only problem ever had was stupid recall starter going out on me and not having time and money to do all the mods I want to do.
 

·
Registered
Joined
·
195 Posts
well 2000 miles on mine and its been in the shop a lot , the clutch fell of after recall . then it poped out of gear had my dealer look at it went by to check what was wrong they had the motor out which I was blown away about but turns out the gear box blew up its been in the dealer for two weeks I missed the fourth and im stuck waiting on parts . this problem would cost 2800 bucks to fix good thing I have the rpm one warrenty with that said we should probably lay of the Polaris guys couse the guy I ride with hasent broke nothing so its more luck of the draw than brand unfortunately .. I do love the maverick a lot im surprised there isn't a post about this issue
 

·
Registered
Joined
·
14 Posts
2013 1000r base model got it back in December 1800 miles all stock beside tires and wheels. winter river riding run it at the local auto x events some ditch bombing and mudding now and then and is my daily driver to work and grocery getter. only issue I had shredding the factory cvt belt at 400 miles ( gotta gates belt now) and tore rear outter axle boot. that prob be my fault for trying to go through anything and everything i can. mostly likely a branch got stuck up in there.
 

·
Registered
Joined
·
1,113 Posts
1012 miles no issues. I love it
 

·
Registered
Joined
·
145 Posts
1844 miles in 7 months. If I had a full time passenger it would be double that. Blown belt at 1844, has went into limp mode twice for over temp when it was not over temped. Turn the key off and reset the computer and it fires up and runs normal. 1 torn CV boot.
 

·
Registered
Joined
·
91 Posts
I have owned mine for 1 year as of today and have 2350 hard miles on mine and have had very little issues that I didn't cause. 2 broken axles , 1 broken rear driveshaft , last week bent 2 rear a-arms on a huge rock. Still loving it.


MaddMack
 

·
Registered
Joined
·
36 Posts
3.6 miles. found a mystery locknut sitting in front bellypan area....looks like 15mm wrench sized. I saw the "maintenance required" flash across the speedo once, also saw "error trans sensor" when I popped it in neutral. Dealer says he filled the tank but it reads just over half.....2/3 ??? in eco mode the throttle really lags and seems to hang up after releasing throttle.....weird. Wondering if I should buy a spare set of tie rods just in case?
 

·
Registered
Joined
·
407 Posts
Buy a set of tie rods and replace them if you wait it could end up costing you a lot more than just a bent rod
 

·
Registered
Joined
·
61 Posts
4300 miles since last November. Most fast and hard riding but not abusing! All trails riding on East coast. Trying to stay out of mud holes!
Have had 2 rad fan failures, replaced rear axles and drive shaft @ 3000 mi. Replaced most bushings on A arm and radius arms over the past 800 mi or so; Original brakes pads lasted 2600 or 2800 mi (was quite impressed with that); Just replaced stock tires this week; Replaced a couple tie rod ends and change original belt at 2500 mi (still looking good, so kept it as back up). and one rear wheel bearing.

Super happy with the machine, given the riding we do and what we put them through! Heading out for a 300 miles run this weekend up to New Hampshire! Maverick is awesome!

Benoit
 

·
Registered
Joined
·
158 Posts
3580 miles an running strong!!!!
 

·
Registered
Joined
·
109 Posts
Discussion Starter #34
Dang loving these high millage machines. Makes me look forword to many many more miles to come on mine. Now if i can just get away from work long enough some more on it.
 

·
Registered
Joined
·
7,381 Posts
man would I love to have that man miles on mine....Only have 1000+ miles on mine and it has been great....
 

·
Registered
Joined
·
109 Posts
Discussion Starter #36
Well got just under a 1000 on it so far now. Still no issues and still love it!
 

·
Registered
Joined
·
147 Posts
Looking right at 165 on my max, Bought in March, just been too hot to get any real ride time in!!
 

·
Registered
Joined
·
310 Posts
I'm at 1600 after this weekend and I see many more in my future.
 

·
Registered
Joined
·
584 Posts
136miles and about 33hrs. no issues so far and I drive the piss out of it and all it see's is mud in east texas
 
21 - 40 of 66 Posts
Top