Can-Am Maverick Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
I am the new owner of a Maverick 1000R. Beautiful, well cared for machine, you can see all the mods done in my signature. I have an issue with it though. The high beam headlights don't seem to function. There has been no modification done to the wiring for them, factory switch as well. Anyone know where I can find a factory schematic for one of these beasts? Anyone else had similar issues? I'd like to get them working again.
Awesome forum here. I'll be here often.
 

·
Premium Member
Joined
·
7,721 Posts
Welcome from Surprise AZ.



I had an issue with mine a couple of times not coming on and it was the switch itself. Its an easy place to start. Tim
 

·
Registered
Joined
·
2,240 Posts
Both my commander and maverick have needed new high beam switch's . Cleaning will work if the contact point inside the switch is not burnt . A high quality after market switch will fix the problem forever
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #8 ·
Hey everyone. Thanks for all the replies. It did turn out to be the switch. I ordered one to replace it. When it gets here I plan on taking it apart and putting a significant amount of dielectric grease in it to prevent this problem again. Cole Hersey make a really good, high quality replacement switch. I'll see if I can find a part number and post it here.
 
  • Like
Reactions: Tmesic

·
Registered
Joined
·
14 Posts
Discussion Starter · #9 ·
Well, whuile waiting for the new switch, I took the old one apart. Found the same carbon tracking others did. Cleaned and the contacts with a pencil eraser and the switch works great. I remembered the pencil eraser trick back from my old slot-car racing days! Still applicable today. :big smile:
 
1 - 9 of 9 Posts
Top