Can-Am Maverick Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
424 Posts
Discussion Starter #1
Like the title says. I have yet to hear about anyone busting or breaking anything in the rear end. Was wondering if anyone on here has heard or seen otherwise!

Thanks!!!
 

·
Registered
Joined
·
3,127 Posts
I remember one person posting up on here that their rear dif broke, but it was apparently defective and BRP replaced it.
 

·
Registered
2019 max R turbo
Joined
·
831 Posts
Guys break them launching hard off the pavement all the time
 

·
Registered
Joined
·
538 Posts
my very first trip with mine i had a horrible rotational noise after a few hours,my dealer diagnosed it as the rear diff,then it turned out to be the gearbox.i think this is probably the one glamisfan is thinking of.
 

·
Registered
Joined
·
4,536 Posts
rear ends are solid !
 

·
Registered
Joined
·
3,127 Posts
my very first trip with mine i had a horrible rotational noise after a few hours,my dealer diagnosed it as the rear diff,then it turned out to be the gearbox.i think this is probably the one glamisfan is thinking of.
If you first posted something about it being the rear diff, then you're prolly the same one.
 

·
Registered
Joined
·
21 Posts
Mine was messed up within the first 100 miles. Making horrible clicking and clunking. Took it to the dealer. They said they couldn't hear it and it was covered so go beat on it. At 425 miles it was so loud it made me nauseous to ride it. Bearings fell apart inside and destroyed internals. ended up replacing the whole unit and both inner cv's


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
5,752 Posts
The Can Am Diffs are super strong. I Had a 120hp to the ground going thru the Arctic cat 650 Diffs and I had to beef up there side cover and it never Broke. The Can Am Diffs are way bigger to so I see no problem with them.
 

·
Registered
Joined
·
1 Posts
Early unit, got it late February. I stripped some teeth off the ring gear. I want to say within the first 100 miles but i cant remember for sure. Very gummy mud, so thick the wheels quit moving then Bang! I wanna say it was defective as i have had nothing else go, axles included. I try not to shock the drive train, let the clutch engage before hammering on it and no jumping. For what its worth the dealer told me BRP said it was the first one they had fail.
 

·
Registered
Joined
·
121 Posts
Mine didn't go bad but dealer said it had a lot of shavings in it and looked like pinion gear wasn't wearing right so they are replacing it.
 

·
Registered
Joined
·
1,103 Posts
That's what I heard.. so far so good... my commander melted down a rear end at 500 miles..but the maverick is supposed to be rock solid..

Sent from my SCH-I545 using Tapatalk
 
1 - 15 of 15 Posts
Top