Can-Am Maverick Forum banner

1 - 20 of 57 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Bought a mav about 2 months ago didn't really run any rzr's till after my 10hr service raced my buddy's xp and he has about 3 machine lengths on me! I didn't reset the maintence required code but does that really matter? I love it for a lot of reasons over my xp but damn I thought 101 hp would have beat the xp. What's wrong? Anyone else having this issue?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #2
I also was reading about the rpm's hitting 8000 and I know I'm not but after 33 pages on here I don't think I read the fix.
 

·
Registered
Joined
·
81 Posts
make sure that you are in 4wd. if you are in 2wd you will get beat everytime.
 

·
Registered
Joined
·
4,536 Posts
whats your top speed
 

·
Registered
Joined
·
19 Posts
I'm hitting 8050 rpm and 79 mph with my maintenance MSG still showing. I've seen 80 a few times but not enough to claim it my top speed. 12.5 hrs on my mav.
 

·
Registered
Joined
·
1,387 Posts
Sux for u. Make sure y'all are running the same size tires and don't race anyone with a turbo
 

·
Registered
Joined
·
292 Posts
I've raced about 7 different xp's and I beat them all about the same (2 to 3 lengths) on a 300 feet dragstrip.You should have know problem as long as the xp's are stock and you are stock. Like RZR hater said you have to be in 4 wheel drive.
 

·
Registered
Joined
·
1,272 Posts
Maybe yours is having the clutch issue!, if its shifting out early and dropping rpm's down to the low 7000's then you'd be lucky to beat a 800.. Watch your rpm's on a straight away and see if its holding 7700-8000 anything less and your fucked..
 

·
Registered
Joined
·
806 Posts
Definetly be in 4wd. The first one I raced, I was in 2wd and he beat me by a few lengths and I was pissed until I seen where we took off and I had left 3 inch ruts for 20 yards.
 

·
Registered
Joined
·
853 Posts
I'd say "learn 2 drive". Any stock Mav vs any stock RZR is no race. The mav wins every time. All of my camp friends have RZRs and none of them except one (tons of engine mods) can beat me. And that one RZR destroys everyone for the record. He's spent several 1000 on his engine like the Trinity Racing Big Bore Kit, Cam, Clutch and more.

In the dirt use 4wd for sure, you will spin the back tires. On the pavement 2wd does just fine.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #13
3 runs on dry pavement 2wd sport high all the xps where bone stock! I love the ride and comfort but man if you are hitting 80 I would need a runway seems like it so long to get 70 mph.
 

·
Registered
Joined
·
6,621 Posts
3 runs on dry pavement 2wd sport high all the xps where bone stock! I love the ride and comfort but man if you are hitting 80 I would need a runway seems like it so long to get 70 mph.
Somethings not right. I have also raced XP's and like an earlier post, around 3 car length's in 300 ft everytime.
you should also be getting up to at least 73mph. Mine get's to 73 in the sand.
 

·
Registered
Joined
·
853 Posts
3 runs on dry pavement 2wd sport high all the xps where bone stock! I love the ride and comfort but man if you are hitting 80 I would need a runway seems like it so long to get 70 mph.
Congrats, you're the first Mav owner to get spanked by a RZR.

Take it back to the dealer and have them look at the clutch.
 

·
Registered
Joined
·
292 Posts
Are you running stock tires? what are your RPM's doing from take off to topend? I can drive right away from a xp from a dead stop or a 20mph roll.
 

·
Registered
Joined
·
1,272 Posts
Sounds like your in the boat with some of us that got the slow ones...I think mine is a 800 with 1000 stickers on it.

Unless some just have shitty clutches and springs. Maybe like mrrpm mentioned before, maybe are throttle plates are shutting for no apparent reason. I'm willing to bet your not hitting rpms like a lot of us aren't.... Cause mine won't spin on black top unless my tires are covered in mud..

By the way does anyone know if the clutches are setup differently from west coast to east coast?????
 

·
Registered
Joined
·
461 Posts
Sounds like your in the boat with some of us that got the slow ones...I think mine is a 800 with 1000 stickers on it.

Unless some just have shitty clutches and springs. Maybe like mrrpm mentioned before, maybe are throttle plates are shutting for no apparent reason. I'm willing to bet your not hitting rpms like a lot of us aren't.... Cause mine won't spin on black top unless my tires are covered in mud..

By the way does anyone know if the clutches are setup differently from west coast to east coast?????
If your rpms are dropping at 45-50 take it back to the dealer and have them replace the secondary spring. Mine had the same issues. Replaced it and all is well. I also got the torsional secondary spring from ///Airdam that I'm going to try this weekend.
 
1 - 20 of 57 Posts
Top