Can-Am Maverick Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter #1
So I've seen this a few times and I'm not sure why. The switch will be in the two wheel drive position but the 4x4 symbol will flash on the dash? Has anyone else experienced this?
 

·
Registered
Joined
·
492 Posts
Do you have sport low? I have the switch less sport low and have been having error issues since installation. Wonder if that is the cause.
 

·
Registered
Joined
·
112 Posts
Talk to arctic bomb about the error you are getting he has a way to fix it. He says sometimes you're machine is wired different. Explain to him what is happening and he'll send you an additional harness.
 

·
Registered
Joined
·
107 Posts
Never had the light flash, but the other day I was running in the back of my property and had to go through a small mud hole. I tried creeping in 2wd to avoid a mud bath and of course I started to spin. I hit the 4wd buttom (of course I was stopped) an nothing. Still 2wd. Tried going in reverse a bit then forward again to maybe see if it just wasnt engaging. Nope. No 4wd. So after hammering it to get out of the mud hole and spraying mud everywhere after just washing the damn thing lol, I made it back to the house. Checked the fuses and found the 5a fuse of 4wd/2wd blown. Replaced it and all is well now, but why and the hell did it blow the fuse. I may have hit the button while rolling forward the other day, would this of caused it? I havnt even had the thing a week yet and already having issues. What gives? Anyone else have this problem?
 

·
Registered
Joined
·
1,777 Posts
My fuse blew as well. My Maverick was stuck in 4 wheel drive and when I switched it to wheel drive the indicator still showed 4 wheel drive. Easy fix but it concerns me that the fuse blew.
 

·
Registered
Joined
·
998 Posts
While in 2wd my 4wd light flickers on and off during the whole ride .. Someone said it was a ground but I haven't traced it down
 

·
Registered
Joined
·
7,381 Posts
That fuse also feeds the winch switch and the illumination for all of your switches. You may have gotten water in one of them when you washed it and shorted it out and blew the fuse….

Power Distribution.jpg
 

·
Registered
Joined
·
211 Posts
I noticed it happening to me last weekend. After I switched it into and out of 4 wheel drive one time it stopped for the rest of the ride.
 

·
Registered
Joined
·
1,777 Posts
Good point Heavy but I'm wondering also if it could be due to the actuator not being able to engage in either drive in a certain amount seconds. Like the load on the actuator is too long.
 

·
Registered
Joined
·
7,381 Posts
I guess it always could be….are you shifting while sitting still? I heard a lot of people are shifting on the fly. I have before but try to stop and do it if i can….
 

·
Registered
Joined
·
1,777 Posts
Well I normally stop but I could have been slightly rolling and just not thinking straight at the moment. Sometimes the excitement fogs the common sense.
 

·
Registered
Joined
·
1,777 Posts
To your point about the water, im going to cap or cover the winch connectors now that you mention it.
 

·
Registered
Joined
·
395 Posts
I know its says not too, but in a two hour Ecors race this weekend, I shifted in and out all race plus practicing all weekend. I also do it when I trail ride, hit the switch before I hit the big water or mud hole then switch it back to 2wd on the fly. Drag racing, take off in 4wd then 30 ft out switch it back to 2wd to free up horsepower, works great. Not seen any problems. Plus have done it this way since 2007 on a 800 Renegade, no problems, the light seems to go out faster when you are rolling.
 

·
Registered
Joined
·
189 Posts
The 4WD indicator flashes on & off the dash frequently when 2WD is selected on both my 2012 Commander Limited and my 2013 Maverick XRS while "cruising" and I believe it is engaging briefly as I could tell this while turning sharp on pavement (30 mph) as it "pushed" when the light was on. Could this be a differential or sending unit problem? Seems odd that both my machines have the same problem?
 

·
Premium Member
Joined
·
91 Posts
when my maverick is in 2wd, the light on my dash will come on when im accelerating. It comes on more when the outside temp is cooler. Any ideas why
 

·
Registered
Joined
·
876 Posts
Subscribed. Interesting read, curious to see if it's I'm fact a faulty ground/connection or something to do with the actuator.
 
1 - 20 of 21 Posts
Top