Can-Am Maverick Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
317 Posts
Discussion Starter #1
Spent the weekend out at Glamis for my first trip since I had the slippery washer update/recall done. I had zero issues before the recall, so I was hesitant to have it done. Well after a weekend of pretty hard riding, it is still in one piece. No issues after the update! We only logged about 160 miles, but I am confident it will hold together. I noticed about 5 other Mavs out there this weekend, its pretty funny all the Mav owners were waving at us when we would go by. One thing that really made my day was on Saturday at the sand drags, there was a orange XP with a turbo that was pretty much smoking all the quads and SXS's, then a guy in a really nice newer lifted dodge truck(daily driver) with paddles and a quad loaded in the back, lined up with the XP and broke him off by about 10 lengths! The guy in the XP was eating black smoke and soot the whole way! About 25 minutes later we saw the XP being towed to camp! Put a smile on my face! That truck was really fast. He even broke off a couple of long travel cars. I will say though, that XP hauled ass, almost pulling the front tires off the ground the whole way. Cant wait to see someone turbo a Mav!
 

·
Registered
Joined
·
728 Posts
Glad to hear you have confidence. I hope you clutch holds up. My Maverick is 2 1/2 weeks old and I haven't had a chance to drive it yet. I fail as an owner.:tongue:
 

·
Registered
Joined
·
175 Posts
I was in the same boat, after recall my first ride at Gordon’s Well sand dunes; however mine was one of the ones that exploded. Everything went as expected and it seems to be holding together I don’t know if it is just me but it sure seems that it is running at a lot higher RPM then before I had the recall done, anybody else notice that. Also is it just mine or does any of you get a lot of sulfur smell mine only has 100 miles on it I’m hoping it will go away.
 

·
Registered
Joined
·
1,319 Posts
Put 180 miles on mine this last weekend at the dunes, first ride since recall & also had zero issues. No odors either, but it was pinned most of the time.
 

·
Registered
Joined
·
317 Posts
Discussion Starter #5
Mine performed exactly the same after the work. I never had any sulfur smell, do you get that smell after it warms up, or right from the start? The only thing I can think of that could make that smell is the battery.
 

·
Registered
Joined
·
175 Posts
Im thinking it is the new cadillac converter burning off, or I have a exhaust leak? I smell it about half the time when I slow down or I am going slow.
 

·
Registered
Joined
·
1,681 Posts
Keep in mind guys, just because it has the recall kit on it doesn not mean that the bolt is not not getting tighter. The Washers are not a fix, but a Bandaid. The only true fix for the issue is to key the sheave so it doen not spin, like 98% of clutch's on the market.
 
1 - 7 of 7 Posts
Top