Can-Am Maverick Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I just got my full hard coated windshield from emp. Anyone having problems with the trim they give you to keep it from rubbing the good falling off? Not sure if I need to try and get it tighter down on the hood or move it up so it barely touches. I stopped 3 times in 2 miles to fix it before I just took it off and went home. Thanks in advance if anyone has suggestions.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,113 Posts
Never had an issue with mine. It is a bitch to get on. Have t make sure its on all the way or like your having an issue it will fall off.
 

·
Registered
Joined
·
410 Posts
I had the same problem, it scratched my wrapped hood and I couldn't move it down anymore. I got a piece of small rubber fuel line and cut it to fit, it works great and since it's black you can't tell what it is unless you inspect the shit out of it.

Sent from my XT1060 using Tapatalk
 

·
Registered
Joined
·
21 Posts
Discussion Starter #4
Well I put it on in the cold. I'm hoping that maybe they just got too cold to fit right. Got it warming up in the basement. But the fuel line sounds like a good alternative it warming it up doesn't help.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
410 Posts
Well I put it on in the cold. I'm hoping that maybe they just got too cold to fit right. Got it warming up in the basement. But the fuel line sounds like a good alternative it warming it up doesn't help.


Sent from my iPhone using Tapatalk
It seemed to me that the trim piece was made to fit a thinner material.
 

·
Registered
Joined
·
21 Posts
Get the trim piece started and tap on it with the handle of a hammer. Worked for me.
 
1 - 6 of 6 Posts
Top