Can-Am Maverick Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
2,963 Posts
Discussion Starter #1 (Edited)
I got my CVTech primary a couple months ago. For whatever reason, the weight and spring combo that AIRDAM set me up with just wasn't cutting it. RPM's were way off. Adam seemed to think I might have gotten a bad primary spring, so he sent me a new spring and enough weights to try a few different combinations. After messing around with it most of the weekend I FINALY got it dialed in. I changed the primary from the 1015, to a 1016. I changed the weights from 3, 2004's and 3, 2005's to 3, 2004's and 3, 2006's. My engagement is at around 1900 rmp, and from a dead stop I punch it and pull 8000 rpm and drop to 7750 rpm at around 45 mph, but climb back to 7950rpm by about 55 mph. From there I'm holding a steady 7950 to 77 mph. No problems with shifting, like I had befor either. I think I can live with that.:big smile:
 

·
Registered
Joined
·
649 Posts
I got my CVTech primary a couple months ago. For whatever reason, the weight and spring combo that AIRDAM set me up with just wasn't cutting it. RPM's were way off. Adam seemed to think I might have gotten a bad primary spring, so he sent me a new spring and enough weights to try a few different combinations. After messing around with it most of the weekend I FINALY got it dialed in. I changed the primary from the 1015, to a 1016. I changed the weights from 3, 2004's and 3, 2005's to 3, 2004's and 3, 2006's. My engagement is at around 1900 rmp, and from a dead stop I punch it and pull 8000 rpm and drop to 7750 rpm at around 45 mph, but climb back to 7950rpm by about 55 mph. From there I'm holding a steady 7950 to 77 mph. No problems with shifting, like I had befor either. I think I can live with that.:big smile:
He sent mr 1016 and 2006s and 2035s
 

·
Registered
Joined
·
2,963 Posts
Discussion Starter #4
thats what he sent me, but with an exra 2006. I had the 2004's and some drilled out 2005's. I ran the 2035's 1st, then the 2004's. Then I tried the drilled out 2005's. The 2004 ran the best. I then tried per Adam's note he sent with the weights, running 4 2006's and 2 2035's. 3 2004's and 3 2006's still ran better. Now I'm probably gunna need some new tires. The asphalt just tore em up. Plus I'm lucky deputy dawg didn't catch me doing 77 in a 45 (several times), operating an off road vehicle......lol.
 

·
Registered
Joined
·
568 Posts
Installed mine Saturday that I got from Adam, and it didn't start engaging until 4k rpm and wasn't smooth either. Pulled it off and put the stocker back on. Trying to get ahold of him or Kris. I don't care who helps me out as long as I can get back to throwing dirt!
 

·
Registered
Joined
·
468 Posts
Installed mine Saturday that I got from Adam, and it didn't start engaging until 4k rpm and wasn't smooth either. Pulled it off and put the stocker back on. Trying to get ahold of him or Kris. I don't care who helps me out as long as I can get back to throwing dirt!
Whoa.... something major league wrong with that thing
 

·
Registered
Joined
·
568 Posts
Whoa.... something major league wrong with that thing
Bingo. When it came in the invoice had xp 900 on it. Called Adam, text, pm'd and he called promptly. Assured me after asking a couple questions that it was for a Mav. Had my friend that does my work contact Kris and Russell and I have a xp clutch according to the weights and springs. Here's your chance Adam at ///airdam. Ill ship it back and you make it rite. I want a QSC, at cost, ill pay the difference. But you don't touch the settings, Ill get it done myself. You have 24hrs.
 

·
Registered
Joined
·
711 Posts
the weights were XP spec??? i just looked at your build card of your clutch. i can assure you, that there is nothing in your clutch that i would put in an XP. i believe you are getting your information from folks who are trying to make me look bad, definitely not from folks who are trying to help. it seems that whenever something is wrong, everyone tried to blow it up and make a huge scene to try and make themselves look better.

your primary has a spring in it that should be an 1800-1900 engagement. i say should be because it "should" engage around 1800-1900. after assembly i check the primary and make sure they open and close properly. yours should not have anything that would hinder it from closing untill 4,000RPM. that seems mighty excessive and absolutely and most definitely wrong. give me a call back when you get the voicemail i left you.
 

·
Registered
Joined
·
568 Posts
Ok. So here's the story. When I posted this originally I was getting second hand info, and I was pissed. Come to find out they were saying the tuning was geared more towards a xp. Which made sense because it came packaged with an invoice that said xp 900 on it. Don't ask for pics, my phone won't let me for some reason. Still don't know why the 4k engaging was happening. He tried to contact me once at my old #, and left me a pm saying he did. I pm'd him a good # and have never heard from him. I've tried contacting him with no luck. I'm sending the clutch back on a trade for a QSC for a substantial hit. Thanks for the customer support \\\airdam.
 
1 - 19 of 19 Posts
Top