Can-Am Maverick Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
459 Posts
Discussion Starter #1
Has anyone else had an issue with climbing hills and having a chugging sensation from the clutch? It's happening at slow speed mostly under a load. 2013 maverick.
 

·
Registered
Joined
·
7,381 Posts
are you in low gear or high? What you are describing is your belt slipping...if you are on tight technical trails or climbing, make sure you are in low gear and consider getting a sport low override kit. It will allow you to run full power in low gear.....
 

·
Registered
Joined
·
459 Posts
Discussion Starter #4
It does it in both high and low, yes tight technical trails but also loading on to trailer with a tilt gate, dealer says he sees no issue with clutch whatsoever. Is this the norm for these bikes or should I just trash the factory clutch.
 

·
Registered
Joined
·
459 Posts
Discussion Starter #6
Where can I get the sport low override kit?
 

·
Registered
Joined
·
7,381 Posts
It does it in both high and low, yes tight technical trails but also loading on to trailer with a tilt gate, dealer says he sees no issue with clutch whatsoever. Is this the norm for these bikes or should I just trash the factory clutch.
The debate on the stock clutches is endless. Some have good luck with them stock. Others have put clutch kits in them and have been happy. Then there are those of us who have put in aftermarket clutches and haven't looked back. Yes, it is a big purchase but i have no regrets and am pleased with the performance gains.....read up on the subject and make your own call. If you decide to pull the trigger, be prepared because you will get 10 people tell you 10 different things. I have the QSC/STM setup that I purchased from Cold Blooded Performance. Kris is a great guy to work with and he can get you all set up and has excellent customer service preand post sale....
 
  • Like
Reactions: PLAY-DOH

·
Registered
Joined
·
2,964 Posts
Sounds to me like a belt issue. Try a new belt, break it in correctly and see if you still have an issue. New belt is much cheaper than a new clutch.
 

·
Registered
Joined
·
459 Posts
Discussion Starter #10
I'm at the dealer right now, they are putting it back together with the new recall bolt and shims, we'll see what happens. Thanks for all the input guys it's been a lot of help. I live in Fort Worth I ride a lot of local places and some out of state, hit me up if your around and we can rip some trails.
 

·
Registered
Joined
·
459 Posts
Discussion Starter #11
Belt only has 22 hrs on it, I broke in exactly how the manual said, but that's the next move. The bike is only a month old.
 

·
Registered
Joined
·
1,298 Posts
TOSS THE BELT< ITS BAD, I have seen 1 event in person where a belt caused that and for what ever reason it was a bad belt. get a new one, break it by the book, add a sport low over ride and ride it like you stole it and your good to go
 

·
Registered
Joined
·
6,621 Posts
sounds to me like a belt issue. Try a new belt, break it in correctly and see if you still have an issue. New belt is much cheaper than a new clutch.
^ x2
 

·
Registered
Joined
·
459 Posts
Discussion Starter #15
thanks guys
 

·
Registered
Joined
·
3,631 Posts
all the canam clutchs aftermarket and factory will slip at low low speeds under a load you cant climb anything slower then 5 mph and when your loading it on the trailer you have to use low and dont stop
 
1 - 16 of 16 Posts
Top