Can-Am Maverick Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
As the title says I have a P0299 code on my 22 maverick RS RR. I have had it come one once before when I was cruising around the neighborhood. It shut off the next time I took it out riding. Then today I pulled it out to wash it and went around the neighborhood and it came back on. My list of mods are S&B particle separator, agency side dump exhaust, and a K&N filter. All mods have been on with a half a dozen rides and No check engine light. With the light on I don’t think there is any performance issues. I’ve check all the vacuum lines and all the connections from the turbo out to the exhaust and don’t see anything obvious. My guess would be something to do with the exhaust but then that’s after the turbo and shouldn’t affect the boost… I’ve got a 4 year warranty and had an appointment to take it in but then it shut off so I didn’t go in. I also don’t want to play the game where they say because I’ve done A and B it caused this and isn’t covered so pay up scenario. Is there a scan tool for a 22? I’ve tried to look for the code shooter but I don’t know if it works on a 22? Thanks for your help and input.
 

·
Premium Member
2020 X3 X RS RR
Joined
·
1,456 Posts
Dirt, Dirt and more dirt getting past it. The factory or Donaldson are amazing. No HP gains are to be had with that filter. You will need BUDS to see the actual performance of the sensors. Just check all the clamps on the charge side from the turbo, intercooler, throttle body and intake. The sensor and a bunch of clamps are easy to get to from the rear.
 

·
Registered
Joined
·
250 Posts
Check clamps, pressurize the turbo system with special tool and soapy water, check wastegate calibration should be 9psi at 1mm and 15.5psi at 5mm on a RR, boost solenoid stuck open ,there is a bunch of things that can cause low boost. Buds2 is the tool you want for diagnostics.
 

·
Registered
Joined
·
2,498 Posts
that k&n may cost you a turbo
there are a few like you found out the hard way
you know warranty wont cover it
search this site and see for yourself
the 22 factory intake/filter is a good unit
I would inspect the compressor wheel for damage
it may be too late
 
  • Like
Reactions: OVRKLL.LAB

·
Registered
Joined
·
1,192 Posts
Is there a way to test map sensor or clean it? The k&n filer was factory oiled and I blow them off with air. What wrong with k&n filters besides the oil?
They add zero HP and let more dirt into your engine.
 
  • Like
Reactions: OVRKLL.LAB

·
Premium Member
2020 X3 X RS RR
Joined
·
1,456 Posts
Well, you need to see if you have low boost from a bad turbo, loose connections on the charge side or a bad sensor. The K&N won't cause this code from lack of flow but could have sanded the turbo from poor filtration.

You need a good shop or your own hacked BUDS to get this fixed without just throwing endless parts at it.
 

·
Registered
Joined
·
2,498 Posts
that code is a low boost code
not a bad sensor code
you have a boost leak
or your turbo is junk
there is no vacuum line on the exhaust
so what did you unplug?
if you unplugged the blow off valve
that will cause it to leak
they need boost to stay shut...lol
 
  • Like
Reactions: 10mm_

·
Registered
Joined
·
2,498 Posts
no its a boost leak
only vacuum at idle
if you had a vacuum leak you would have a faster idle
 
1 - 19 of 19 Posts
Top