Can-Am Maverick Forum banner
1 - 20 of 23 Posts

· Registered
Joined
·
367 Posts
woohoo!
Our very own section
 

· Registered
Joined
·
88 Posts
ok so lets see these awesome machine's in action.
 

· Registered
Joined
·
367 Posts
Mine are leaking down now.
Woody did they tell you exactly what the problem is?
 

· Registered
Joined
·
88 Posts
I took my drivers seat out and found the nice deep marks in the snorkel. So please be careful putting you seat back in.
 

Attachments

· Registered
Joined
·
806 Posts
Looks like the rubber grommets missed the pegs and caused that.
 

· Registered
Joined
·
7,381 Posts
Looks like the rubber grommets missed the pegs and caused that.
That's exactly what happened....look and you can see where the rear feet of the seat were sitting next to the peg/stud instead of on it. Operator error..... :wink:
 

· Registered
Joined
·
806 Posts
Exactly.
 

· Registered
Joined
·
367 Posts
im gonna take some rubber tubing and zip tie it to that area
 

· Registered
Joined
·
367 Posts
Woody
You said it was a recall on the compressor...
Is it possible that it was a service bulletin?
Do you have the can am number they issued on the paperwork by any chance?
Mines going in to the shop on Thursday.
 

· Registered
Joined
·
88 Posts
yall guy were right about the operator error lol. so I looked the passenger side seat and It want even latch down. it does not even line up with the pegs. so off to the dealer 2marrow. fun
 

· Registered
Joined
·
7,381 Posts
yall guy were right about the operator error lol. so I looked the passenger side seat and It want even latch down. it does not even line up with the pegs. so off to the dealer 2marrow. fun
I take it your dealer didn't go over all of that with you when you bought it.....it is easily to not get it latched......
 

· Registered
Joined
·
88 Posts
no they did not. they just got the can am line and I was the first can am buyer they had. if I line up the pegs than the latch is in the middle of the metal that holds the latch pin. I will take a pic and post it in a minute. maybe something is bent. idk
 

· Registered
Joined
·
1,113 Posts
Alot of guys are using low for anything under 40mph and high after that. I use
It when hill climbing and slow technical stuff. I dont mud ride but if you do use it then. Not sure if your going to plow snow but for those of that have to use low also for that.
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top